How do i set right refresh rate for my monitor, and how do i stop getting 30 fps

Hi everyone!
Anyone can help me to find out can help me here with setting up refresh rate for my monitor on Manjaro. Basically i wanna set 74Hz for my monitor. But since i am using an NVIDIA GPU i can’t use xrandr . So i have to set /etc/X11/xorg.conf and /etc/X11/mhwd.d/nvidia.conf . But i just don’t know how. So that’s my conf for both, anyone can see if i need to modify something?

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 455.45.01

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    # 1920x1080 @ 74.00 Hz (GTF) hsync: 83.40 kHz; pclk: 217.50 MHz
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer SA220Q"
    HorizSync       31.0 - 75.0
    VertRefresh     56.0 - 75.0
    Modeline       "1920x1080_74.00"  217.50  1920 2056 2264 2608  1080 1081 1084 1127  -HSync +Vsync
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1660"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "1920x1080 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Also i want to know why do i get 30 fps.
Cause i came from Windows. And there when i benchmark my GPU i got 60 fps while with Manjaro i got 30 fps instead and with all the drivers installed.
Anyone can help?

1 Like