How do i remove pipewire and go back to pulseaudio?

When i run sudo pacman -S pulseaudio pulseaudio-bluetooth in a terminal i get the error error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency ‘pipewire-pulse’ required by manjaro-pipewire

Edit: i failed the embed thing.

pacman is developed by Arch and might not work as well as pamac with Manjaro metapackages
If pamac cannot deal with Manjaro metapackages, issue can be reported to Manjaro team for attention

I suggest either:

  • Install manjaro-pulse to replace manjaro-pipewire
    pamac install manjaro-pulse


  • Remove manjaro-pipewire before installing pulseaudio and pulseaudio-bluetooth
    pamac remove manjaro-pipewire; pamac install pulseaudio pulseaudio-bluetooth
1 Like

If you prefer pacman, it’s simply

sudo pacman -S manjaro-pulse

and then answer yes to all replacement questions.

It has worked now and i have pulseaudio back thanks, would you also know how to install the pulseaudio socket? i keep getting this error.

Setting up Pulseaudio socket
Failure: No such entity

Please create a separate topic for a different question.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.