How do I prevent updating from changing default kernel to the latest?

I am on Stable Branch and using kernel 6.1 for default kernel (this earlier post explains why I use 6.1).

But I find that an update changes the default kernel to 6.6 (I presume because it is the latest).

A concrete example would be today, when I applied the “2023-12-10” update. Before the update my default kernel was 6.1.64-1, but after the update it had become 6.6.5-1.

For now I have a fix.

Namely, after applying an update, restart machine > preemptively press Esc > choose “Advanced Options for Manjaro Linux” > choose 6.1. > which (I understand) automatically makes my choice the default kernel so long as I have these lines in my /etc/default/grub.



  1. Is an update supposed to change default kernel to the latest? (Or is something gone wrong my machine?)
  2. Is there a way to prevent that automatic change? I can imagine (a) a line in /etc/default/grub or (b) some option added to sudo pacman -Syu, which in either case says, “Leave the default kernel alone!”
  3. If not 2, is there a command I could use after an update (from the Ctrl+Alt+F2 screen), which is equivalent to pressing Esc and choosing 6.1 from “Advanced Options for Manjaro Linux”? For example, could that be: sudo mhwd-kernel -i linux61 ? (I used sudo mhwd-kernel -i linux66 to install 6.6, but now am only trying to choose–and thus make default–a kernel already installed, i.e. 6.1, and so I am probably wrong there.)

If the kernel is installed and there is updates to the kernel the process will trigger a rebuild of the grub.cfg which will make the latest kernel the preselected.

I suggest you remove 6.6 until VMware catch up …

sudo mhwd-kernel -r linux66

Another thing to try, editing /etc/default/grub (as root)

  1. GRUB_DEFAULT=saved

Save the changes and rebuild grub.cfg

sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

That’s brilliant. I will do that.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.