How do i navigate to "pam.d"?

after running update and restart, manjaro won’t boot. I came across a post that has a solution ( i can’t post links but the title is “Wont Boot After Restart” ) in it it says to edit “pam.d” but I’m not sure how to navigate there.

it’s /etc/pam.d/ directory
for new user, you can copy partial url as _ttps:// :wink:

haha ok i will use that workaround in the future. when i type /etc/pam.d/ it just says :bash /etc/pam.d/ is a directory, and does nothing i need to add/remove some stuff as stated here _ttps://

you use command “cd /etc/pam.d/”

This basic command line navigation, stands for change directory

I suggest taking a look at some linux basics …
such as my favorite zoo tutorial:

But basically … to ‘change directory’ you use cd

cd /etc/pam.d/

Then you can print working directory (see where you are)


You can also list what items are there


If you want to invoke a command on an item there, such as text editor nano…

nano file1.txt

You also didnt need to navigate there… you can always just feed a whole path to something. ie:

nano /etc/pam.d/file1.txt

But … you need admin/root priveleges for system files … so you would need ‘sudo’. ie:

sudo nano /etc/pam.d/file1.txt

And more … but again … I suggest you look at some of the ‘getting started’ or ‘basics’ tutorials.


thanks, I’ve tried that, but I’m not sure on how to list all that stuff like they did in the article.

If you mean to list pacnew files the easiest is probably

pacdiff -o

PS … for more specifics on pacnews and suggestions on how to handle them see

System Maintenance - Manjaro Linux
Good tutorial around pacnew needed

Thanks. I typed “sudo nano /etc/pam.d/system-login” and got this output

auth       required
auth       requisite
auth       include    system-auth

account    required
account    required
account    include    system-auth

password   include    system-auth

session    optional
session    optional       force revoke
session    include    system-auth
session    optional          motd=/etc/motd
session    optional          dir=/var/spool/mail standard quiet
-session   optional
session    required           user_readenv=1
auth       required

is missing in both places, would i just add

auth       required

where pam_tally is supposed to be?

No… its only necessary to replace the deprecated module if its there.

Note … I saw some reference by one user who had a pam file in home though.
~/.pam_environment I believe it was. Might be worth checking there.

I warn anyone, ~/.pam_environment is not read by default since the version 1.4.0

It’s not common knowledge so I spread that around.

EDIT: it has to be enabled and it wasn’t in Arch maybe Manjaro has
PSA: [testing] pam-1.4.0 disables reading ~/.pam_environment by default : archlinux
pam_env: Change the default to not read the user .pam_environment file · linux-pam/linux-pam@f83fb5f · GitHub

If this is the case… hopefully someone edits the wiki with that info:

I can’t find user_readenv=1 anywhere so I guess it’s not enabled distrowise. My lazy buttox could just test it :smiley: but I don’t like having to relogin.

Edit: maybe this could be split into a separate thread.