How do I install driver for ethernet without internet?

I’ve been using manjaro for like 4 years, but I still think I’m a newbie-ish, so please bear with me if I’m not specific enough.

I’ve just purchased a new desktop, and I tried installing manjaro via a usb stick (most recent official image w/kde).
Now I noticed I cannot reach internet at all.

When I tried ip link it only shows 1: lo: ... and not the ethernet device.

I tried inxi in the terminal, and what I got is something like

  Device-1: Realtek RTL8125 2.5GbE vendor : Gigabyte driver: N/A
  modules: r8169 port: 3000 bus ID 05:00.0 chip ID: 10ec:8125

(Yes, I just typed with my hand… there can be typos)
I believe it saying “driver: N/A” means I have not installed the driver for the ethernet. The thing is, I don’t have alternative method to connect to ethernet, and my desktop is situated in a university where internet is only accessible when I provide MAC address to them to get a clearance and a static IP address. Practically, I cannot pacman anything right now.

So, how can I install the driver, and make my computer online?
Or, how can I specify to install the drivers necessary to connect to internet while I install manjaro?

It looks like maybe you want this?

OK, I have 3 questions.

  1. Is it r8125 or r8169? Are they different, and if they are, why my module info says “r8169” while the device is RTL8125?

  2. How can I install it w/o internet? Can I use a USB stick to transfer this?

  3. Is there any way to specify for this to be installed from the live USB stick from the very beginning? or any compatible ones?

Your device seems to be a RTL8125 … the module the system is trying to use is r8169 … which doesnt seem to be working.

The manual way for aur packages using makepkg. But in this case you need to have a few things: the headers for your kernel, dkms, and the AUR prerequisite group base-devel on top of the AUR package itself. You would need to provide those somehow - such as on a USB.

Other than something like above then you would need build an ISO with 8125 in it.

1 Like

If you have smartphone at hand, easiest would be to use USB tethering to make the downloads.


Thank you for the descriptions. It makes much sense now. So I presume this is unexpected, “bug”-ish things that will be corrected in the future releases?

Wait how could have I not thought about this? This might not be a solution to the problem, but a beautiful way to bypass it. I’ll try if that works tomorrow!

1 Like

Update: It does not work, sadly.
I remember me doing this kind of stuffs a lot of times, but as of now, the wired (usb) connection is shown with “yellow triangle with !”, and despite it being displayed as “connected” it does not load up anything. I checked if this works with other machines, and of course it works with other machines, so I think this is not supported by factory-state manjaro.

One thing I was wondering is if I should try to install an older version of manjaro, but I really don’t want to get into such mess…

Edit: I was mistaken to judge it was working with my old manjaro machine. BTW I found some forum threads on iOS14 usb tethering not working. Perhaps I need to see if this is the case or not.

After turning on USB Tethering you should restart the system. And yes while booting, USB Tethering should get off you have to turn it on again.

Hope it helps. If it doesn’t which phone are you using Android or iPhone. On Android it works perfectly fine for me.

Problem I think is that iPhones needs some packages not installed by default.

Here’s the update: everything is settled now.

1 . iPhone issue.
iOS14+ seems not to be able to tether internet to linux via USB. This seems to be deliberate move by Apple, or at least “I don’t care” move, as some users complain in the Apple forum (Link to the post).

2 . Attempts and workarounds to get the internet
One way I could have my machine to get on the internet was to use bluetooth, since not only my iPhone but my laptop could also tether internet via bluetooth. I have a bluetooth dongle on my old manjaro machine, but when I connected one on my new PC it did not work. It seems it requires a driver…and I needed internet to download that as well. So I’m stuck in a bootstrap again.
Another was to use an USB wireless LAN card (with drivers built in to be automatically installed…), which nowadays is very hard to come by because basically everything has Wi-Fi receiver now. I could not find one, so I am not sure if that’d work without the internet to install the driver.

But I managed to find an USB ethernet LAN card, which worked for some reasons (it seems to be using another Realtek chip, which seems to be an older one, that could be why). I used that to upgrade the system and install r8125 (thanks to cscs) from AUR. Speaking of which, why did yaourt get discontinued?

Anyway thank you all for the replies, it helped me a lot to overcome this. I hope I don’t have to suffer this kind of shenanigans when I migrate to the next machine. Perhaps I need to learn how to make an ISO with specific packages included.

Yeah - usually ethernet works out-of-the-box.
But your new one is very new - the dkms AUR driver was first submitted on the 21st of this month.

yaourt was rather always a broken aur helper.
It did things in a hackish way … and had a number of flaws - both for system stability and security.
But as far as I know its still available - seems to be in the AUR again.
But I heavily suggest not using it.

You’re welcome. Glad its sorted.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.