How do I get my USB install stick back? dolphin right click ownership to - whatever has gone!

I upgraded hardware to NUC10i5FNK but after installing manjaro- (requires a swap for some reason)
I find I can’t get ownership of the stick back. So I can’t write to it.
I’m the only user and I have the admin password

I used to do dolphin right click root options ownership to -
But that has disappeared.
The services menu to add it just fails to install all the root options. (open dolphin as root /or/ root options services menu.) “Failed to execute install script”

Mindbogglingly even kde partition won’t wipe it. Why can’t I just format the stick?
I thought linux had gotten past making users get down on their hands and knees to do everything.

1 Like

Thanks for the fast response.
It moved things around a definately did something the stick now appears 8.8gb instead of 16gb
The part that remains showing still has all the root directories from when it was an install stick
But when trying to copy to the device I get access denied could not write file…

The information given is sparse - and actions requiring root permissions cannot be done using Dolphin. It may have been possible in the past but as KDE is moving towards wayland they are slowly removing options which are considered unsafe for the general stability of the operating system.

Compare it to the old days with Win XP where you could do whatever you wanted to the jail of Windows 7 where unsigned drivers where banned.

Almost the same thing.

Use the terminal and sudo to change ownership of your USB stick if that is your problem - but if it is because you have written and ISO then no chmod or chown will do because an ISO is effectively - at least for Manjaro - ISO9660 which per definition is readonly.

You need to reformat the stick if it has been used for ISO purpose - that is how it is.

Create the script referenced - and save it to ~/.local/bin as eg. format-usb - make the script executable using chmod +x - then list your devices using


Use the script to format the stick to exFAT.

format-usb /dev/sdy

Remember to unmount before formatting - because trying to format a mounted device yields all kinds of weird errors.

So unmounting it helped with kde partition editor somehow I can now format it ext4 etc or write the manjaro iso over it again. It’s back to 16gb

But both of these have the same problem that the ownership is set to root i guess and I can’t even drag a file to a blank usb stick after kde partition editor leaves it. There seem to be no options to assign ownership in kde partition editor. and dolphin won’t even ask for the root password to check if I have authorisation to copy.

You’re right I tried a few chown things but as access is denied they do me no favours.

That is normal - as you create partiton(s) and filesystem as root - they will be root owned.

The thing with exFAT is that it is permission agnostic - so any system can read and write exFAT.

But as you say you have used ext4 - then it is root owned - and the tried and tested approach to change that is to open a terminal and mount the device then chown or chmod using sudo.

Or if your device is already mounted at /run/user/$UID/${some-uuid-or-partition-name} you can do

sudo chown $USER:$USER /run/user/$UID/${some-uuid-or-partition-name}

or if permissions suffice

sudo chmod o+rw /run/user/$UID/${some-uuid-or-partition-name}

Yes you’re right it is possible to write to exfat or vfat. It’s just the ext4 and installiso that is denied.

I clearly don’t understand permissions. Having used the graphical easy way all along.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.