How do I get MIDI music to work?

Good day,
I recently installed System Shock: Enhanced Edition (GOG version) and noticed the MIDI music does not work. The only MIDI device option is Port-0 (Don’t know if this is relevant)

I have Duke 3D installed on my system as well and the MIDI music worked just fine the last time I played it, a few months ago. (I ran it in BuildGDX primarily but also eduke32)
I then started Duke 3D and noticed the MIDI music also no longer plays when using BuildGDX. When I go into Duke 3D’s settings it says “Initialization failed”. Previously it allowed me to select different things for MIDI.
Sound effects seem unaffected.

I have Fluidsynth and lib32-Fluidsynth installed (Official Repositories).
I have Soundfonts-fluid installed (Official Repositories).
I also have dsound and directmusic installed via Winetricks.

I don’t know when or why the MIDI music stopped working, since it has been a few months since I played a game that required it.

I saw this post in ProtonDB, but it is for the Steam version (I have GOG). I am also not quite sure how to do what he say as I’m fairly new to Linux.
System Shock MIDI

If what that post says is the solution to getting MIDI music to work again I would appreciate some help in how to implement it.

If there is another way I would appreciate any help.