How do I fix my auto screen rotation?

Hello, I am a beginner with Linux, I am trying out Manjaro, KDE Plasma, Wayland for my first experience, and have ran into a problem with my ASUS 2-in-1 T101ha tablet in short, the screen doesn’t auto rotate, and on system startup, it is rotated 90° counterclockwise.

I have looked online for solutions to this problem, and have found a couple, unfortunately, none of them have worked yet.

I would post links, but I currently don’t have the required trust rank.

Many solutions mention “install iio-sensor-proxy”, when I tried this an error was thrown back at me.

mkdir: cannot create directory 'iio-sensor-proxy/build': File exists

I assume this means it’s already installed? a different solution involved a setting “orientation function” in display settings, and that doesn’t show up for me.

Any help would be appreciated, thank you.


How did you tried to install it? You should be fine with
pamac install iio-sensor-proxy

Remember, you might have to enable the service for it
systemctl enable iio-sensor-proxy.service

Try X11 session as wayland might not yet be suitable.

Thank you for your quick reply.

since I’m new, I don’t know whats considered “standard” for installing this sort of thing, but, I used the “git clone” command, then the “makepkg” command (after the cd command).

I just tried to enable it as you said, but got this error

Failed to enable unit: Unit file iio-sensor-proxy.service does not exist.

I’ll try a different session, but…
1). will this get rid of my data?
2). how do I do that?

Open up Pamac and if a package is in our repository, install it from there.

You just log out and chose the Plasma X11 Session. Has nothing to do with losing your data …

Thanks, It now seems to be successfully installed, but enabling it still didn’t work

The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.

I then tried switching to a Plasma x11 session, and that also didn’t work.

Please remove your git clone install of the iio-sensor-proxy and install it from our repos as i mentioned previously … Reboot the system after that and check the status:

systemctl status iio-sensor-proxy


systemctl status iio-sensor-proxy.service

I have now done that, and it says it’s active.

and it doesn’t work. Maybe It’s because it can’t tell if its in tablet mode or not.

Never mind! I switched back to wayland because my touch controls were being weird and now it works! thanks for your help!

Solution (provided by bogdancovaciu):

  1. If you’ve already installed iio-sensor-proxy via the git clone command, remove it via
sudo pacman -R iio-sensor-proxy
  1. Install iio-sensot-proxy with pamac
pamac install iio-sensor-proxy
  1. Enable it
systemctl enable iio-sensor-proxy.service
  1. Reboot computer

  2. Check status to make sure It’s running

systemctl status iio-sensor-proxy
  1. Try it out.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.