How do I enable Thunderbolt 3 on a MacBook Air 2014?

I know from Apple’s hardware specs of my laptop, I have Thunderbolt 3, but I could not get it to work. I installed bolt and plasma-thunderbolt, as shown by the ‘sudo pamac list | grep bolt’ command, but when I run ‘boltctl’, nothing shows up, and plasma thunderbolt doesn’t show up as a program when I run it in the terminal. Am I doing something wrong?

The thing with Apple branded hardware is - it usually works best with macOS.

Not all hardware has been reverse engineered and applied to Linux.

Perhaps this is a such kind of hardware?

You tagged with xfce - why?

There is a page with resources for Apple hardware using Arch Linux on Laptop/Apple - ArchWiki

Thunderboltd and boltd are two programs doing the same thing, so it’s either or but not both.

However, i think aarhus is right and it doesn’t work on your hardware.

Do these devices have some kind of BIOS to enable or modify the settings?

In some cases a properly registered device id can be sufficient to allow detection; however, how that may translate to a Linux environment, I simply don’t know.