How do I enable rEFInd to load at boot?


I have the latest version of XFCE and refind bootloader on my computer. however on restart the computer immediately loads manjaro without giving me the option of loading another OS. What can i do to enable loading the bootloader? Apologies for the little technical knowledge but i am new to manjaro.


Have you studied the wiki already?

Another source of inspiration:

no absolutely not. thanks for the heads up.

OK, I looked at both but still haven’t a clue what to do. Can you lead me through enabling refind as you would a complete beginner.

We have a helpful program in our repos called manjaro-refind-installer you can try.

did you mean the forum?

I’m no expert, byebyeapple, but I use rEFInd and I play around with various Linux distributions every now and then. Sometimes a new Linux installation will “hijack” the boot sequence and boot directly to the newly installed Linux system. To remedy this I go into my Dell PC’s BIOS settings and change the boot order so that rEFInd is number 1 again.

I assume you are using an Apple product and if so then I can’t be of much more help here. I don’t know how to change the boot order on an Apple system but I’m sure someone else can chime in.

Edit: And Yochanan’s suggestion to install manjaro-refind-installer may be all that you’ll need to do. Search for it in the software app “Pamac.”

Huh? Search for manjaro-refind-installer in Add/Remove Software or from the terminal:

pamac install manjaro-refind-installer

thanks! i did install refind via add and remove but even after this it doesnt automatically go to it on restart the computer still just reboots directly into manjaro. Do i need to press any specific keys to encourage it to load refind?

You are right about the boot order. I need to access the bios and change the boot order. The problem is that i dont have a clue how to do that on my imac. it used to be option R but that doesnt work now that im locked into the manjaro OS.

I thought about why refind was being sidestepped and concluded that grub bootloader was hijacking the boot process so as i didnt know how to access the mac bios and proritise refind as number 1 i went back into manjaro and deleted the grub bootloader in add and remove programs. I then rebooted to what looked like a grub command line. I typed ‘exit’ and lo and behold it took me to the refind bootloader. I selected manjaro and it took me to the grub command line again. I had no choice but to press exit again and load mac os. I feel like this experiment with manjaro has run its course. I will try another Linux distro having more confidence in being able to remedy the situation should it happen again. shame i lack the expertise to remedy it. There must be plenty of people trying to breathe life into old macs by replacing mac os.

Well, Arch Wiki has notes applicable to some Apple products.

You may get some inspiration from there. Most documentation for Arch is also relevant for Manjaro (There are exceptions though). :slightly_smiling_face:

So is it indeed solved or did you just move on as you had posted? I don’t think of this as a Manjaro issue but rather an imac issue. Someone out there can help you. Maybe this?

You said you previously were able to use Option R to access bios. I’ve only seen references to Option without the R. Maybe I just don’t understand. Never the less, I hope you’ll give Manjaro a little more time.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.