How do I disable my camera microphone?

Hello everyone, I want help to configure my microphone, I would appreciate any tips. So I have two microphones: the microphone of my webcam REDRAGON (which I don’t want to use), and the microphone from my headset HyperX. Everything works fine when I don’t use echo cancell and noise reduction from a tutorial that I’ve followed on the internet. If turn on my computer only with the HyperX microphone connected, it works fine with noise reduction and echo cancel, but if I turn on my computer with both microphones connected (Camera and Headset), only the camera microphone works and the microphone of Headset disappear from my configurations. So I want to block completely the microphone of REDRAGON camera, is it possible?

The tutorial that I’ve followed says to add the lines

load-module module-echo-cancel aec_args="analog_gain_control=0 digital_gain_control=0" source_name=noiseless


set-default-source noiseless

at the end of this text file

sudo nano /etc/pulse/

also, here are information of my machine

inxi -Fxz                                                        ✔ 
  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: GNOME 41.2 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2006
    date: 11/13/2019
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1725 high: 3891 min/max: 1550/3400 boost: enabled
    cores: 1: 2532 2: 1338 3: 1556 4: 1375 5: 1549 6: 1367 7: 3891 8: 1557
    9: 1434 10: 1292 11: 1442 12: 1375 bogomips: 81470
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 08:00.0
  Display: x11 server: X.Org driver: loaded: amdgpu,ati
    unloaded: modesetting,radeon resolution: 1920x1080~70Hz
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 447.13 GiB used: 103.36 GiB (23.1%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-1: / size: 58.76 GiB used: 23.43 GiB (39.9%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 196.9 MiB used: 274 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 344.23 GiB used: 79.93 GiB (23.2%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: file size: 1024 MiB used: 0 KiB (0.0%) file: /swapfile1
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1123
  Processes: 309 Uptime: 8m Memory: 15.62 GiB used: 2.32 GiB (14.8%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1279
  Shell: Zsh v: 5.8 inxi: 3.3.11

Hi @denielt,

I don’t have Gnome, so might be wrong.

Isn’t it as simple as muting it in the sound configuration?

just install pavucontrol and go to the “Configuration” tab at the very right and disable your webcam’s microphone by choosing “Off” from the dropdown menu.

Well, it wouldn’t solve the problem… cause muting the device would not make me able to use HyperX microphone, since when REDRAGON camera microphone is being used I can’t use any other microphone with echo cancel and noise reduction. Anyway I just found a way to block my webcam to be read as an audio device here’s the link Blacklisting your USB Webcam's built-in microphone in Linux this is exactly my problem. I’m trying to fix following this tutorial right now.

1 Like

Tried to do it but the system just turned it on again

Please provide the output of:

sudo lsusb

both before as wel as after the webcam is plugged in.

1 Like

So, here’s the solution I found:

using the comand lsusb I found a list of USB devices, and which one I wanted to add to blocklist (my microphone camera)

lsusb                                                            ✔ 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 09da:2690 A4Tech Co., Ltd. REDRAGON Live Camera
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 258a:1006 SINO WEALTH USB KEYBOARD
Bus 001 Device 002: ID 0951:16d3 Kingston Technology HyperX Pulsefire Surge
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

After identifying the device I created a rule to add his addres in a blocklist creating a configuration file: sudo gedit /etc/udev/rules.d/90-block-webcam-sound.rules and in this file I configured my usb camera to not be read as an audio device

SUBSYSTEM=="usb", DRIVER=="snd-usb-audio", ATTRS{idVendor}=="09da", ATTRS{idProduct}=="2690", ATTR{authorized}="0"

Now the only microphone working in my computer is the HyperX microphone from headset.


Found a solution, Mirda, thank you so much for your effort and willing to help!

1 Like

Happy you managed!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.