How do I disable "Enter password for default keyring" when opening Google Chrome?

Everytime I open Google Chrome on my Manjaro system, a prompt asks me to enter a password for my default keyring. I know this password as, I believe to remember, I had to enter such a password when I opened Google Chrome for the first time.

I must have overlooked something because I couldn’t really find helpful answers for this issue on the internet. Besides, a lot of the search results on Google referring to a Manjaro forum are not working as there seems to be an issue with SSL certificates!

Try this:

rm ~/.local/share/keyrings/* Now open Chrome, if it asks you for your password, do not enter one choose Continue each time and ignore any warnings.

Check here for more details: https://askubuntu.com/questions/31786/chrome-asks-for-password-to-unlock-keyring-on-startup

Thank you kindly for your reply @limaunion ! Just as you were typing out your suggestion, I posted this reply:

I have found a working solution! The forum post [ I can not post links ] suggests these following commands:

sudo mv /usr/bin/gnome-keyring-daemon /usr/bin/gnome-keyring-daemon-old
sudo killall gnome-keyring-daemon

I executed them and the next reboot it did no longer ask for my ‘default keyring password’.

Now, as there was literally zero context provided, I am wondering what consequences these commandos have for my system. Why does it result in no longer needing to enter a password and why isn’t it the default when using Manjaro?

I’m quite sure nobody finds to have a more productive OS by needing to enter it, so there must be a reason it is enabled and a catch to disabling it using the provided commands - I’d like to know the catch because I want to learn everything about Manjaro before I start recommending it and installing it on the computers of my friends and relatives.

1 Like

Try deleting --password-store= entry from google-chrome.
BTW it is a security feature that encrypts your Google Chrome password.

Thanks for your suggestion @garvitjoshi9 ! I have some trouble understanding your idea, as I don’t know what kind of entry you mean!

How does one “delete an an entry from Google Chrome” and what is a “Google Chrome password” - do you mean the passwords stored by Google Chrome (the password manager) or something else?

Are you using KDE or GNOME.
In KDE:

  1. Right-click on Google Chrome Application.
  2. Go to properties.
  3. Click on Application
  4. In the command section clear --password-store= entry.
    In Simpler words --password-store= in .desktop file.

Hi. I am having the exact same issue on Manjaro GNOME. What is particularly perplexing is that I installed GNOME on a laptop and desktop within a few weeks apart under the same release before GNOME 40 and the laptop has no issue with the keyring yet the desktop machine keeps asking for it. Both machines went through the rolling release update to GNOME 40 without any problems. I have dealt with this before in the past in Ubuntu by resetting to a blank password and it worked. But when I do that on the my newer Manjaro GNOME desktop machine, I cannot sync Chrome to my Google account. The 10+ year old laptop works flawlessly without a problem. Any suggestions on what may be causing this so I can grasp the root of the problem? I have not changed anything in the command line. Thanks! :+1:t3:

Not sure if anyone can use this but it helped me. It is based on an older version of Ubuntu Mate.:ok_hand:t2:

How-To Fix "Enter password to unlock your login keyring" - YouTube