How do i decrypt my home directory?

So i decided to start using Linux, so i went for Linux Mint because everyone seemed to recommend it, but i had some problems with it (kernel panics on shutdown) so i hopped to Manjaro, the thing is, my Home folder was still encrypted because of Linux Mint (.ecryptfs/henrique) and i couldn’t login on that user anymore because it would just go back to the login screen, so i tried removing it and adding it again through another user (this one wasn’t encrypted), but the problem is still there (probably because it’s encrypted), what do i do?

to access your encrypted data - and back it up

or directly restore it to your current installation’s $HOME directory

or just keep using the encrypted $HOME … once you have installed ecryptfs-utils

a couple of options …

best and easiest is probably to install ecryptfs-utils and back up the contents after having decrypted it - then restore the (decrypted) contents it to your current $HOME

how do i use ecryptfs-utils to access my encrypted data though? (installed it)

I used it a couple of years ago.
I’d now only know when I looked up again how it is used.
You can surely do the same thing. Like I did back then.

But someone else might know already and could guide you.
I can’t. :man_shrugging:

i tried that but when i do ecryptfs-recover-private /home/henrique/.Private, then insert my passphrase it just says this:

mount: /tmp/ecryptfs.a9KPO9rL: mount(2) system call failed: No such file or directory. ERROR: Failed to mount private data at [/tmp/ecryptfs.a9KPO9rL].

(i used ‘su -’ before doing this command btw)

not enough information
the command looks wrong - overly specific
Where is your encrypted home directory mounted?
If it is in your current $HOME then something like this might find it and help you mount it
ecryptfs-recover-private /home/henrique

You have to try reading and understanding the man pages
man ecryptfs-recover-private
says you can give it a PATH to where the encrypted stuff is - it will search through that entire directory

I can only speculate - not actually help, since I don’t have a thusly encrypted directory to play with.
That might actually be a good point:
play with it - create an encrypted directory and learn how to use it, access it.

Then you know how to access the data you care about …

so i tried it again but this time using my login passphrase (i tried it before but it didnt work) instead of the mount one and apparently it worked!
im not sure if its because i mounted it to /opt/henrique_home (i was trying to do something a guy said was the solution in a thread but i probably did it wrong)
anyways thanks for the help :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.