How do I deal with Developer Edition?

Here now again a question in the english part of the forum ( thanks @anon88624618 ): I want to install a developer edition of Manjaro. How do I go about getting the downloaded or manjaro-kde-21.07-development-unstable-210708-linux510.iso.z01 onto the stick? Unpacking does not work for either file. How do I get the .ISO?

Download both files. Unpack the .zip, which should yield you a .iso from both of the compressed files.

This is exactly what does NOT work. When I try to unzip, I get an error message from Ark: Multi-disk zip archives not supported! Otherwise I would have already sorted it out myself :wink:

I installed unzip again (currently using Arch, must not have been installed yet) went to the folder where the files are located, but only the message: bash: unzip: command not found came up.
I give up, why also necessarily play the tester … wait until it is stable …

No - don’t just give up! What does ls /usr/bin/ | grep zip say?

Most likely unzip is not installed. Install unzip with sudo pacman -S unzip

That is up to you. More testers would help the distribution to be even better.

1 Like

Please try to install it again like @archisman advised.

OK, I had tried yay, must have been nothing. With pacman it worked, but the file can not be unpacked:

[uwe@HAL Downloads]$ unzip
warning []:  zipfile claims to be last disk of a multi-part archive;
attempting to process anyway, assuming all parts have been concatenated
together in order.  Expect "errors" and warnings...true multi-part support
doesn't exist yet (coming soon).
file #1:  bad zipfile offset (local header sig):  4

It insists that the file must be part of a multi-archive.

I’ll let this shit go now, the whole thing just came out of a whim anyway. Sorry and thanks for your effort …

You need first combine all files into one, then unzip:

zip -s- -O
1 Like

Sorry, I’ve been trying to unzip this crap for over an hour now, with no success worth mentioning … why am I doing this to myself? Am out … :roll_eyes:

Did I say one last try? I must have used a script or alias or something and forgot about it, because I was wrong. What does work for me is:
zip -FF --out


Tested it just now…
Sorry about that…

P.S.: zip is a separate package you need to install.

EDIT: Just in case you wanna try again after a good night’s sleep :slightly_smiling_face:

Oh good grief. Did anyone search the internet?

The Linux unzip utility doesn’t really support multipart zips. From the manual:

Multi-part archives are not yet supported, except in conjunction with zip. (All parts must be concatenated together in order, and then zip -F (for zip 2.x) or zip -FF (for zip 3.x) must be performed on the concatenated archive in order to “fix” it. Also, zip 3.0 and later can combine multi-part (split) archives into a combined single-file archive using zip -s- inarchive -O outarchive. See the zip 3 manual page for more information.)

So you need to first concatenate the pieces, then repair the result. cat* concatenates all the files called* where the wildcard * stands for any sequence of characters; the files are enumerated in lexicographic order, which is the same as numerical order thanks to the leadings zeroes. > directs the output into the file

cat* >
zip -FF --out

If you created the pieces by directly splitting the zip file, as opposed to creating a multi-part zip with the official Pkzip utility, all you need to do is join the parts.

cat* >


That’s too easy :smile:

I checked the forum and installed PeaZip and it created the iso then used it to install the gnome dev edition.Been using it several months now with no major issues.

Download the file e.g.:

In the terminal:
7z x manjaro-xfce-21.07-development-unstable-210710-linux510.iso.z01

And then you will get your ‘.iso’ file

1 Like

thx @paulm1 , THIS has now worked! :+1:t2:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.