How do I configure keybindings without screwing up the others?

Hello, I use the latest release of Xfce. I went into the Settings Manager, Keyboard, and changed my keyboard language shortcut to Left Alt (Change layout option) + Left Ctrl (Compose key).

After that I try to use normal Alt+something and Ctrl+something shortcuts and they don’t work. Neither in the desktop nor in other software (I can’t copy paste in Firefox, can’t bold anything in LibreOffice, can’t switch tabs with Ctrl+Tab, can’t change apps with Alt+Ctrl).

Anybody knows why is this and how can I fix with without changing back my language switch? I’ll try to clean it and see what happens, but still, I’m interested in a way to do this in my system.

Edit: I removed the bindings and everything works fine again. Still, pretty interested in how to actually configure keybindings without screwing up the others, haha.

Thank you so much.


I added language layout the other day as well. My Compose key field is empty.
My Change layout option is Both Ctrl together. It works.

Only fill the Change layout option field with one of the given options.

I don’t know for sure why is that, but it probably interferes with the regular combos somehow.

If you want to see the language mode in the panel go to:
settingspanelitemsclick add and search for Keyboard layout.
There you will be able to From there you can set the key combo as well if you wish.

1 Like

if what you mean is - I want to keep the default and define others as well overwriting defaults - it won’t work.

It is sheer luck if you define overrides for your window manager and they actually work.

What I mean is - you actually have to redefine the shortcuts for the xfce window manager - for this to work.

What I mean is that I didn’t expect to configure a keybinding for keyboard layout and that it would broke other keybindings completely. I assumed that this keybinding would work as a separate combination that wouldn’t affect other shortcuts, since I don’t recall Left Alt + Left Ctrl as a shortcut to anything else. I’ll also admit that I’m not well-versed in how this works, so I’ll go read about xfce window manager. Thank you for the insight. :blush:

I went with @GokuSan’s approach and it worked like a charm. It’s not my preferred keybidings but it works.

Ever heard of Ctrl + Alt + Del or Ctrl + Alt + L. There are others, though I’m not sure what bindings xfce has by default.

You use one or more modifier keys to modify a key. They are meant to do nothing on their own, you shouldn’t even be able to make those binds.