How do I compile/install a tar.gz file that requires a manual update?

I probably could just reinstall the entire program through pacman (could be wrong) but I’d rather just learn how to manually update it (the program stated I needed to manually update it) so I don’t have to run into the same issue again. Issue is, I have no idea how to compile/install the tar.gz file to run it (i.e., discord), and have tried understanding how to install it through the arch wiki via this link but failed.

More specifically, I tried going directlly to the extracted file directory and used makepkg --install as well as qmake -makefile in my confusion. There doesn’t seem to appear to be any files named “configure” nor a “PKGBUILD” file from my understanding (I checked the entire directory and used the ./configure command as well) so I’m not sure what to do. Can anyone help?

Lets stop right there.
So this is a package you have installed from the repositories? As a package?
Then you should likely ignore whatever warning it is giving you and/or update your entire system.
You do not manually upgrade packages. Even using the package manager one should not attempt to upgrade a single package. That is what is known as a partial upgrade. And it is equivalent to broken.

I’m not sure what you downloaded exactly … but if it was a compiled package … then I would not expect a PKGBUILD to be present, and you are not expected to ‘build’ it.


Maybe you could explain further - which package exactly? And how was it installed?
And what ‘error’ do you get?

I don’t think it’s from the repositories, it’s from an official source through the add/remove software program (which I understand is essentially just pacman for all I’m aware), and stated that it’s current version is 0.0.36-1 and version 0.0.37 is available when I tried launching it, stating that I would manually need to update it, giving me options for which file type to install, i.e., a Ubuntu debian file or the linux one, which is the tar.gz file I downloaded over the link provided and then extracted into my downloads directory.

Thats pamac (not the same as pacman)

And that would mean ‘from the repositories’ unless its a third party source like AUR, Flatpak, Snap.

Would you please tell us the actual package name?

discord-0.0.37.tar.gz

You may want to read both posts in this “How To”

So … you have discord installed from the repositories.

Discord is dumb and doesnt understand dependencies and discord sends mass messages to users to ‘upgrade’ …

Instead you should follow your mirrors.
(or if it bothers you, switch branches or use a different source like Flatpak, etc)
https://packages.manjaro.org/?query=discord

Looking … thats all besides the point, as it appears that the current .37 is available on all branches…

So your system is simply out of date.

sudo pacman-mirrors -f && sudo pacman -Syu

The above will sort mirrors first … then sync and update all (native system) packages, as the good penguin intended.

The above will sort mirrors first … then sync and update all packages, as the good penguin intended.

Thanks for clarifying this. Not exactly familiar with konsole commands just yet… have only been using Linux in general, more specifically only manjaro’s plasma version/distro for probably a little less than a month as of now total so am still very much a noob with these things.

I’m not much of a fan of pamac, but you should be able to use it for updates as usual.

It is possible the mirror sort was helpful.

The pamac GUI would be the same as

pamac update

Though, I might suggest omitting the AUR, at least on first pass:

pamac update --no-aur

Which is supposed to be equivalent to the OG pacman update:

sudo pacman -Syu

(note: pamac can handle multiple software sources including the AUR, pacman only manages local and repository packages)

You should not need to sort the mirrors again, and any of the above should do a normal upgrade in the future.

(if you omit the aur, then upgrade it afterwards with your helper, eg; pamac upgrade -a --devel or paru -Sua or yay -Sua --devel , etc)

I have this in my notes about discord and updates.

In ~/.config/discord/settings.json make sure to include "SKIP_HOST_UPDATE": true,

That way it should ignore updates in the app.

1 Like

The last time I had issues I installed webcord - which is practically identical, but open source.

Try it and tell me if you see any difference :wink:

There are invisible differences, though…

Webcord blocks some of the telemetry used by Discord and has some nice features.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.