How do I change the DPI of my graphics card?

On my other laptop I had the same problem as described here I don’t use this driver anymore. I now use the video-nvidia-390xx driver and have no switch driver installed.

Here is my lspci -v | grep -E 'VGA|3D':

01:00.0 VGA compatible controller: NVIDIA Corporation GF104GLM [Quadro 4000M] (rev a1) (prog-if 00 [VGA controller])

And here is my inxi -G:

  Device-1: NVIDIA GF104GLM [Quadro 4000M] driver: nvidia v: 390.154
  Device-2: Chicony Integrated HP HD Webcam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: nvidia gpu: nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: Quadro 4000M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.154

So now my DPI is to big and when I change the DefaultDepht in section Screen of the config file: /etc/X11/mhwd.d/nvidia.conf from 24 to 20 I get A black screen after booting from grub. I solve this by going in to the rescue terminal (Ctrl+alt+f2) I reinstall the graphics card driver via mhwd.

So my question is where do I change my DPI? Or is that even possible since my graphics card is old and has to have legacy drivers in order to work.

I’m also currently working on an other problem because my Intel graphics driver isn’t showing up. So just to provide enough information here is my: inxi -Faz:

  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=e817a2de-5865-4464-a8c7-699536c78f21 rw quiet
    resume=UUID=d5291e4f-366e-4c90-beb4-d46c1e4dd94c udev.log_priority=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 8760w
    v: A0001D02 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 1630 v: KBC Version 01.39
    serial: <superuser required> UEFI: Hewlett-Packard v: 68SAD Ver. F.23
    date: 01/18/2012
  ID-1: BAT0 charge: 59.3 Wh (95.2%) condition: 62.3/62.3 Wh (100.0%)
    volts: 16.4 min: 14.4 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: N/A
  Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i7-2820QM bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 969 high: 1391 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 985 3: 798
    4: 798 5: 924 6: 798 7: 1260 8: 1391 bogomips: 36735
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF104GLM [Quadro 4000M] vendor: Hewlett-Packard
    driver: nvidia v: 390.154 alternate: nouveau,nvidia_drm non-free:
    series: 390.xx+ status: legacy-active (EOL~late 2022) arch: Fermi
    code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0e3b class-ID: 0300
  Device-2: Chicony Integrated HP HD Webcam type: USB driver: uvcvideo
    bus-ID: 2-1.4:4 chip-ID: 04f2:b230 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 128 s-size: 381x211mm (15.00x8.31")
    s-diag: 436mm (17.15")
  Monitor-1: LVDS-0 res: 1920x1080 hz: 60 dpi: 128
    size: 381x214mm (15x8.43") diag: 437mm (17.2") modes: N/A
  OpenGL: renderer: Quadro 4000M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.154
    direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF104 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0beb class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: 5020 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 25:00.0 chip-ID: 8086:4238
    class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-3: HP hs2340 HSPA+ mobile broadband type: USB
    driver: cdc_acm,cdc_ncm,cdc_wdm bus-ID: 1-1.2:4 chip-ID: 03f0:3a1d
    class-ID: 0202 serial: <filter>
  IF: enp0s26u1u2i6 state: down mac: <filter>
  Device-1: HP Broadcom 2070 Bluetooth Combo type: USB driver: btusb v: 0.8
    bus-ID: 2-1.6:5 chip-ID: 03f0:231d class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
  Local Storage: total: 704.24 GiB used: 22.24 GiB (3.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7PC256HAFU-000H1
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 5H1Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500VT000-1DK142
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: MBC1
    scheme: GPT
  ID-1: / raw-size: 221.06 GiB size: 216.53 GiB (97.95%) used: 22.24 GiB
    (10.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.11 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 64 C
  Fan Speeds (RPM): N/A
  Processes: 237 Uptime: 27m wakeups: 3 Memory: 15.56 GiB used: 1.63 GiB
  (10.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1360 pm: pacman pkgs: 1355
  libs: 324 tools: pamac,yay pm: flatpak pkgs: 5 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21

I’ve also tried changing /etc/sddm.conf to enable HiDPI on line 30 and 38. But this didn’t do anything.

So I’ve started searching on the Arch forum to look for any other apply able options and found this thread. Which looks A lot to my older fix when I encounter the same problem. Because I needed to change the variable of the line Option "DPI" "96x96" in the /etc/X11/xorg.conf.d/20-nvidia.conf file.

But this installation of Manjaro doesn’t have that config file for some reason. Here is my ls of /etc/X11/xorg.conf.d/ >> 00-keyboard.conf 30-touchpad.conf 90-mhwd.conf. As you can see there is no nvidia.conf file in this directory. And now I’m clueless of where I need to add the Option "DPI" "96x96" or where to change that variable.

you have installed bumblebee which installed probably with it bbswitch …
your intel is not being detected either because its blocked by bios, or because of bbswitch;
you should post pic how your dpi looks like …
you can change it from system settings/fonts and check force font dpi and set it to desired size, and see if that helps

Okay that kinda fixed the problem (Still have A feeling it looks kinda weird tho…). But it’s good enough for me.

This is the before screenshot

And here is the after screenshot

Thanks again @brahma !

looks normal to me … you can also test setting up the global scale in system settings to 106% and disable the force font dpi, if it looks better to you…

I compared it to my other laptop and it’s normal indeed. I’m not going to touch the global scale, I’m done with this part.

Thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.