How difficult is to bring (Ubuntu) Studio Controls into Manjaro?

Studio Controls

Ubuntu Studio made and is making a great work into implementing and easy to use and totally useful GNU/Linux distro for sound-creation, on professional level.
It so easy that it’s not necessary to know about GNU/Linux, JACK, ALSA or any software of that kind to run the distro.

But here’s the even greater point: Studio Controls, the JACK management tool from Ubuntu Studio distro, can be installed on any Ubuntu derived distro, with perfect results.
So installing Studio Controls into Linux Mint, any Ubuntu and so on, brings the user a functional system for sound-creation.

I suppose that what that package make is to run some scripts for configurations and then the UI for controlling JACK and its bridges.

Pro-Sound on Manjaro

To achieve a professional sound-creation environment on Manjaro or any other Arch based distro, the most easy way is to install JACK2 and Cadence-tools manually, and edit some configuration files, enter user in audio group and so on.

This is not very easy for common users who only want to have a useful system.

Bring Studio Controls into Manjaro (and other Arch based distros)

This would ease a lot the process to have a functional system without manually setting it up.
Some users tested installing Studio Controls on such distros, unsuccesfully; in my opinion, due to the architecture and files to modify are different to those Ubuntu based distros.

As said, I suppose it’s about:

  • Installing some dependencies (need to identify all of them on Manjaro)
  • Executing some scripts to modify configuration files (need to identify the needed changes for Arch based distros)
  • Giving user some privileges and entering it into audio group

So how difficult is to bring Studio Controls into Manjaro?

Not here mate…

No idea. What is it? Where is it? Project link?

Looks like there is already an AUR package:


This was in AUR previously as ubuntu-studio-controls-git

Manjaro already has qjackctl and cadence in the community repository for JACK

There might be a conflict between cadence and studio-controls
When studio-controls was first released April 2019 UbuntuStudio said there were compatibility issues with KXStudio, so using ‘cadence’ was discouraged and not supported
but both packages have developed since then so it may not be a problem now
But I do not know much more about either package; I have been using qjackctl from a time when it was the only GUI option for JACK

You are correct that the core system configuration is not easy by the method shown in the video
but there are easier ways to get Manjaro configured for realtime audio with JACK

Manjaro does not have a metapackage like Ubuntu, but there is an Arch package that does most of what is needed - realtime-privileges
(I am working on a script to sort out the 2 or 3 other things that might need changing but some of the DEs here have default settings that are already good)

realtime-privileges creates 2 files that change 4 system configurations


and creates realtime group for access to this,

The user needs to be in realtime and audio groups
(but PulseAudio does not need to be allowed in realtime :wink:)

Yeah, that’s it. There’s still a compatibility problem with Studio Controls and Cadence.

I didn’t know about thet Arch package. Is it yours, as you said you’re working into a script?

I did know about the groups, most of all about audio, because it’s discussable if the realtime permissions are needed.

Another good thing of Studio Controls, thus my desire to bring it to Arch, is that it automatizes the process of trespassing mastership between devices without stopping JACK (thing that Cadence and Qjackctl don’t); also the ability to configure USB master, more than one devices at the same time… a lot of features!

Therefore, my interest is not only about having a metapackage to setup all permissions, but also to have Studio Controls with all its features :slight_smile:

Then you have the studio-controls-git package in the AUR.

Some users have tried Studio Controls in Arch based distros and they sad it does not work, but I’ll try myself on other machine when I’ll have time.

Sorry for not answering to your previous message, I didn’t enter into the website until today.

Seems the package was re-adopted again recently with a new maintainer and is reported working.

I am not sure which package you were referring to
realtime-privileges is inherited from Arch and I only found it at the beginning of this year just before the youtube video came out
ubuntu-studio-controls-git was the original package name when it was added to AUR in April 2019. UbuntuStudio 20.10 release announcement advised the name change

I had been using realtimeconfigquickscan for a long time, and adding everything in audio group for realtime will still work
but realtime-privileges reduces the number of terminal commands I need
I have done realtime configuration one step at a time in 3 different Manjaro DEs this year and permissions are not negotiable with JACK. If they are not right JACK will not start

I am not sure exactly what ‘trespassing mastership’ means, but I know how to change devices without restarting JACK. One of my old Linux group had an interface with a temperamental USB connection, but the Slackware guy worked out a way around it
Use the dummy driver to start JACK and then load connections with alsa_in and alsa_out
and make a big red button on the desktop to reload the connections if they drop

I did see one Arch forum report about this package recently
from the logs there appears to be some issues with /usr/lib/jack/
but I also see that OP is trying to use a Snowball USB microphone with samplerate 96000Hz
I do not think this device can support that samplerate

I installed studio-controls-git from AUR and it installed also JACK2, so that’s good!
It runs JACK properly so that’s also great.

Some problems that I have are:

  • pulse-jack bridge is not automatically set up and I must connect the ports manually with Carla
  • I’m not able to play streams to headphones, although I have the volumes right on alsamixer *
  • When JACK running, there appears no card on Pavucontrol > Configuration

Some help?

* Seems that the headphones are audible through intel,2,0, but then when unplugging them I can’t hear from speakers (seemly intel,0,0) Now I managed to make this work with QASMixer, seems that some ALSA output ports were muted by default: when starting system, Headphones port is muted on ALSA, and Master is not full volume (this is problematic)

That is part of the built-in functionality of the package, which appear to be very different to any other way of managing connections between JACK and PulseAudio
If the settings for jack-bridges are not working as intended I suggest you contact Ubuntu developers for help with that

This is a good thing (as long as the devices are restored when JACK is stopped)
If an audio device is being used by JACK it will not be available for audio playback direct from PulseAudio
If PulseAudio can still see the device is present and tries to send an audio stream to it the audio playback stream will fail, unless the audio stream is re-directed to the PulseAudio sink

when ALSA settings have been unmuted and adjusted to suit your needs, the settings must be saved so they are restored to the same state when system is restarted

sudo alsactl store