How could I reset all display servers configurations on Bash? / Reset all app settings without uninstalling them?

My problem is relatively straightforward, even though what made it happen isn’t, it appears to me. So, I was looking for a way to scale an application individually, found a tool called run_scaled which was employed by xrandr to create a server for that. I then ran the command run_scaled with the path to the program, but it didn’t open the client, so I tried a few more times until I appended sudo before it. Somehow it probably overrided my display settings, avoiding any application to launch and the login GUI to hung forever when I press enter after filling the fields. Now I would need it to reset I reckon, because the only way my user can log in is through the command line interface. And obviously no graphics can launch there.

I’ve learned my mistake, preppending sudo without it being indicated. But I would like to have the controls back once again. My distro is Manjaro 5 with the .12 release I believe by heart.

Welcome to the forum! :wave:

To you, perhaps. However, your description is not at all straightforward. We have no idea what “display servers configurations on Bash” means. Perhaps post your ~/.bashrc using proper formatting?

See also [HowTo] Request support

Not quite.

lsb_release -a | grep Release


Either way, the release number is meaningless for an existing install on a rolling release distro. The release numbers are only snapshots for ISO releases.

Beforehand, thanks for returning and anyone else who comes hereafter. Yes, I shouldn’t have hurried to send it. With the title I meant the xpra settings and/or the run_scaled utility, which messed up my setup maybe on to permissions too, and any recovery strategy I could use to go through the graphical login interface that freezes once I’ve pressed enter/clicked the arrow to log in. Don’t think ~/.bash.rc would help cause I can still run it, but only on a virtual command line in the locker screen. If I need to sort all the apps back to their installation states I’ll probably do it, if the issue is not actually on a standalone file.

the file name is
~/.bashrc (without the dot)

and the request was to post the contents, to see whether you changed it from it’s original state

What you mean is (probably, possibly) a TTY - which you can reach always by pressing CTRL+Alt+some Fx key.

Your description of your issue still remains very much unclear.

I changed bashrc once but I reversed it back later. Probably remains unchanged since then but I’ll check.

Reinstalling an application does not reset your user settings.

For that to happen you have to remove the relevant configurations from your home.

Look inside folders like ~/.config and ~/.local as the majority configuration reside in those folders.

How about creating a new user? It wouldn’t bring across locally installed apps …

1 Like

The bad is that I’ve tried creating one, it goes ahead but I can’t login as the terminal returns it failed. And I’m sure I typed it correctly, Those were two attempts with different usernames and passwords. I’m assuming it is due to the sudo prefixed in the command I’m alluding to.