How could I edit a kernel parameter?

Hi!! My laptop with an Intel iGPU is affected by some screen pulsating and flickering, this issue is described here:
https://wiki.archlinux.org/index.php/Intel_graphics#Troubleshooting
https://bugs.archlinux.org/task/50605

As the Arch Linux Wiki describes, to fix it I have to disable the Panel Self Refresh (PSR, a power saving feature) by using the kernel parameter i915.enable_psr=0. I’m not sure how to do it, I’ve done a little research and I think I should proceed this way:

Open /etc/default/grub
edit line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash”
add i915.enable_psr=0 in the quotes
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0”
save
sudo update-grub
reboot

Am I right?

1 Like

If that is the correct parameter it should work.
I would add it to the other line:
GRUB_CMDLINE_LINUX= …
That way it only applies to the “normal” initrd - not to the fallback one.

I think you are right.
There is nothing to lose.
You can always edit out that piece at the grub command line should it prevent you to boot at all.
That’s also why it’s better to add it to the other line - so you don’t need to edit but just can boot the fallback option, where it doesn’t apply.

1 Like

This is my actual grub file:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

Is this fix correct?

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 i915.enable_psr=0"
GRUB_CMDLINE_LINUX="i915.enable_psr=0"

If that parameter’s spelling is correct - it should work
of course I don’t know that

in any case
If it doesn’t work with the default image - it should not present a problem in the fallback image
if you put like that

Why do you ask?
Didn’t you test? :wink:

:wink:

1 Like

I’m going to test now, I was only asking before editing the file, just in case…
:grin:

Update: It has worked, thank you very much for your help. :grinning:

good!
no need to thank me - you found and chose the correct parameter
I just told you where to put it in case it wasn’t working, so it wouldn’t be the default as well.

The kernel parameters only need to be on one or the other:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX="i915.enable_psr=0"

is fine. A quick Google search.

2 Likes

Oh - that was unintuitive (for me).
That means I had it the wrong way around in what I said.

1 Like

Already fixed, thanks a lot!!
:grinning:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.