How can the tcl and tk libraries be added to the Tcl/Tk software?

Hello, I’m trying to add the Tcl and Tk libraries to the Tcl and Tk software installations.

I installed Tcl and Tk through the installer tool from the core repository a couple months ago and they’ve been working. Now I want to add the libraries but couldn’t find them in the core repository.

I added the AUR and the three I wanted are there: tclib, tklib, and tkImg.

First, I added the build of tclib since it is a dependency of tklib and it was successful. However, tklib fails to build due to validation of sha256 sum. The tkImg library was successful also.

I know very little about Linux. Is it possible to add the library outside of the installer tool, or another way to get it loaded? The .tar.gz files are available elsewhere.

I tried checking the auto_path in tclsh and using tar -zxf to install the files there, and they unpacked but the require package statements in the scripts failed to locate them.

Thank you.

The what now?

First of all, it’s tcllib. It’s already a dependency of tklib.

Edit the PKGBUILD when prompted and run updpkgsums. Save and continue. Let the AUR package maintainer know by leaving a comment on the AUR page.

Thanks for the response.

I get this error:

Cloning tklib build files…
Checking tklib dependencies…
Resolving dependencies…
Checking inter-conflicts…

Building tklib…

Cloning tklib build files…
Checking tklib dependencies…
Resolving dependencies…
Checking inter-conflicts…

Building tklib…
==> Making package: tklib 0.7-1 (Sat 29 May 2021 08:45:11 PM EDT)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
→ Downloading tklib-0.7.tar.gz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 122 100 122 0 0 495 0 --:–:-- --:–:-- --:–:-- 497

100 2421k 0 2421k 0 0 2473k 0 --:–:-- --:–:-- --:–:-- 2473k
100 6120k 0 6120k 0 0 3873k 0 --:–:-- 0:00:01 --:–:-- 6165k
==> Validating source files with sha256sums…
tklib-0.7.tar.gz … FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build tklib

This is the PKGBUILD:

# Maintainer: Michael Schubert < at gmail>
# Contributor: Thomas Dziedzic
# Contributor: Mihai Militaru <mihai dot militaru at xmpp dot ro>
pkgdesc='Tklib specializes in utilities for GUI programming.'
arch=('i686' 'x86_64')
depends=('tk' 'tcllib')

build() {
  cd $pkgname-$pkgname-$pkgver
  ./configure --prefix=/usr
  make all

package() {
  cd $pkgname-$pkgname-$pkgver
  make DESTDIR="$pkgdir" install

I tried placing updpkgsums in this code after the source is defined and after that attempt then moved it to the end and when it processes it consumes all the RAM and freezes the computer.

I assume I’m doing something wrong. Do you know what it is? Thanks.

Sorry I wasn’t clear.

sudo pacman -Syu --needed base-devel git
git clone
cd tklib
makepkg -srcif

Thank you. I apologize for my lack of knowledge of Linux in general.

Is it correct that this cannot be installed in /usr/lib with the other Tcl and Tk files and tcllib?

I tried and it won’t permit me to use updpkgsums and generates an error if try sudo updpkgsums of danger if run form root.


Do not run any of those commands as root. Notice I only used sudo in the first one.

Thanks. Yes, I did notice that. Then I should put this elsewhere and lappend the location to the auto_path, as described at Tcl/Tk wiki? I don’t have permission to add the link.

It worked anyway and the library packages are found by the scripts now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.