How can I see my battery percentage?

Ok, this is weird.
In my new laptop I cannot see my battery percentage.
I was trying to use the command acpi but is not showing anything.


Also I activated this option:

And I cannot see anything.

Also I tried with a widget and is like this:


And the most important, If I disconnect the energy wire, my laptop is shutting down.
I’m starting to think If I don’t have battery.

Someone can help me or guide me to try to show my battery or something.


What does

head /sys/class/power_supply/*/{type,capacity,present}


I did and anything:

And I tried with: journalctl -b | grep battery and showed me:


Hmm… seems like the expansion works differently than in bash…

I guess we have an answer then.

I boot a usb with Hiren’s Boot CD to check if Manjaro is not detecting my battery or something like that but I saw the same message in Windows.


I always use my computer plugged in, and I haven’t noticed it. I’m an idiot. Now I hope to be able to claim where I bought it.

1 Like

Since you are talking about returning it is probably not the case, but i will write it for other users in the future:
If it is older laptop and does not have some kind of preservation mode (to charge to about 80% on AC), and always charges and holds 100% on AC, the typical life of a Li-Ion/Pol battery is between 2 !! (yes until the end of warranty :slight_smile: ) and 4-5 years and it dies. But dying usually means holding charge for about 5-10 minutes. Completely not detecting is more like broken controller or short circuit. Both cases for warranty claim.

There would likely be no battery level indication below 100% if your machine is always plugged in - I wonder if journalctl -b | grep battery was simply reporting that the battery was not being used.

The kernel is not that stupid :slight_smile:
When everything works (battery on AC, software limited to 80% to preserve it) on a lenovo laptop:

[teo@teo-lenovo-v15 ~]$ journalctl -b | grep battery
Sep 24 17:46:12 teo-lenovo-v15 kernel: ACPI: battery: Slot [BAT0] (battery present)
Sep 24 17:46:18 teo-lenovo-v15 tlp[759]: Setting battery charge thresholds...done.

[teo@teo-lenovo-v15 ~]$ head /sys/class/power_supply/*/{type,capacity,present}
==> /sys/class/power_supply/ADP0/type <==

==> /sys/class/power_supply/BAT0/type <==

==> /sys/class/power_supply/BAT0/capacity <==

==> /sys/class/power_supply/BAT0/present <==

[teo@teo-lenovo-v15 ~]$ acpi
Battery 0: Not charging, 78%

The software that interacts with it can be at times. A wild guess on my part though, as the only laptop I use is on power 99.99999% of the time – battery lasts 5-15 minutes unplugged, last time I checked – I’m never too concerned about its status.

Finally, I opened the new laptop, and the sellers have forgotten to connect the battery.


Now is detected! :slight_smile:

Thanks guys!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.