How can I run the argonone script for argonone V2 case on Manjaro Arm Linux

I’ve been trying for hours to find a solution and couldn’t find anything useful. Can someone give me a step by step tutorial that can help me set this up. I am new to manjiro linux and linux in general and a noob coder.

I don’t recall I ever created a guide on this but I do have a repo for the manjaro version.

Couldn’t make it work.

I run a manjaro powered webserver on a 2GB Pi4 using an argon case with a m.2 disk expansion.

So you probably did something wrong - I can’t fix that.

Please provide the links from the manual - use the example below - I don’t know if they change something since I did my setup - it is unlikely - however possible.


I checked the custom packages.

The one named raspi-gpio-git needed manual intervention as I got the following message error: version mismatch.  This is Automake 1.16.5, but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.16.1.  You should recreate aclocal.m4 with aclocal and run automake again.
WARNING: 'automake-1.16' is probably too old.
         You should only need it if you modified '' or
         '' or m4 files included by ''.
         The 'automake' program is part of the GNU Automake package:
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:

I am not an expert on these scripts - I could fix it by running automake without arguments and rerun makepkg -i - your mileage may vary.

I’ve a Raspberry pi 4 8GB ram. I erased my Manjaro and decided to go for Twister OS. Thanks for the feedback tho.