How can i remove general video file detection (mimetypes or associations) from all kind of video files?

I’m looking for a way to remove video file associations that video files no longer have this little mime video icon and i don’t see a way to get rid of it in the KDE File Associations.

I tried with mp4/mkv files already in System Settings and removed everything there but Dolphin don’t care and still linked this mime icons to this files.

Have you tried removing the Plasma-specific files from ~/.cache?

rm -f ~/.cache/*.kcache && rm -rf ~/.cache/thumbnails/*

Note: You have to do this from a tty, while logged out of Plasma.

You just want to change icons? Change app icons in KDE

Could you explain exactly what you hope to achieve by removing these associations? Do you want to, perhaps:

  1. Choose to play a file without it launching the default program? … or;

  2. Make it so all media files share a system default non-media icon, or maybe a custom icon that you choose?

Option 1 – I really have nothing to suggest that won’t potentially bork your profile in some way.

Option 2 – This could be accomplished by manually installing another icon theme under:


…and editing it, replacing all the media file icons with icons you prefer.

Note that deleting them won’t work as they are substituted for the default failsafe icons if any are missing. When done, make that icon theme your default.

Hope this helps. Cheers.

1 Like

I’m not exactly sure if i understand your command, but as far as i know im only have a normal Icon that i want to remove from all my Video files in Dolphin… just like all video files looks neutral/empty from file browsing perspective.

I have tumbnails disabled in dolphin and use small icon list.

I want to remove this icons. Not replacing it.

My goal is archive more performance… there was a KDE change 2-3 month ago, when i open a folder with alot video files, they all getting scanned and at the same time on my HDD.

I have to wait for maybe 20-40 seconds till i can browse with dolphin, before this changes happends only the first few files was scanned or linked as video file and when i scroll down my HDD had to work again.

So this was the big KDE changes… but i dont need this video markings anyways and i just want maximum performance, i want a empty icon that my HDD dont have to use more performance for a simple file browsing.

Does changing Dolphin’s ‘View Mode’ to ‘Details’ make any difference?

I don’t experience anything like what you describe. My system is quite performant though, so it wouldn’t likely be a problem.

Are you on a desktop or laptop? I noticed you wrote ‘HDD’: An SDD would probably make a huge difference, but that’s not always a practical solution.

I don’t know if there’s a cache setting of some kind that may help; but deleting the cache might be an option, to see if there’s any improvement.
Beyond that, I’m probably out of my depth; which at the moment is about a centimetre from the bottom of my glass.

Change these settings… :arrow_down:


I don’t think you can not remove an icon just for video files. You can change it to the Unknown icon, maybe that will speed things up. I have a folder with 100+ video files (full length movies to watch when the power goes off) it’s a bit slow, but not like you describe. Turning off thumbnails restores the speed. Maybe you can divide the files into multiple folders? How about another file manager? What’s the speed like using the terminal? If you remove the association then you will have to manually select the application every time you open the file, and don’t forget to check “this time only” otherwise the association will return. I don’t think you want that kind of hassle, do you?


Im already use Details thats my preferred view mode.

Im using HDD, thats why i have problems with that… SDD is no solution for me here.

I remember i choosed No Previews was already.

But i just selected Video Files under Show previews… (even it doesnt make sense to me)
And i switched from skip preview for local files above 1MB to No Limit.

No difference for me :frowning:

Yeah maybe, do you know how?

Im actually have no video player association anyways, i just use drag+drop and drop them into my smplayer.

The idea was that you’d set them to the smallest quantity, not to unlimited.

Also, you may want to disable Baloo. I don’t think it will make much of a difference in showing thumbnails or icons if you have that disabled, but Dolphin does get that information from Baloo.

Then i already setup everything there… because 1MB was the smallest amount :frowning:

Baloo is the file indexer, i think i disabled that service in KDE settings somewhere… i have to double check that.

Or is there a SystemD service to disable?

I just typed:

systemctl status baloo

But no luck.

On my system — Manjaro Stable, Plasma 5.27.8 — it still works that way: if it has to scan, then it will do that only on what’s visible in the Dolphin window, and it will only continue scanning if you scroll down.

Addendum: It will only scan once, unless the content of the directory has changed. It stores the results in the ~/.cache directory, and the next time you open up the folder, it will read from the cache.

balooctl status
balooctl status
Baloo is currently disabled. To enable, please run balooctl enable

Strange, i wonder why it changed for me after last 3 stable updates then :face_with_monocle:

Maybe that doesn’t work for me because when i dismount and mount it on next day again because i use Veracrypt.

Do you have a idea how i can remove this icon for video files?

Now you mention that. So it’s not always mounted, and it’s encrypted. Well, yeah, that causes Dolphin to see each new mount as a new filesystem.

Only by editing the icon theme, as explained by @soundofthunder higher up already. :arrow_down:

Sorry, i mean to switch it to unknown file.

Atleast i dont see that in @soundofthunder response.

Then you’re probably going to have to be messing with the file associations, as @fbt89 said. :arrow_down:

Select each and every type of video file, and click Remove on them.

Note: By doing this, you are probably going to be seriously messing up your Plasma installation, so I won’t take responsibility here. I am only telling you how to do what you insist on doing. :man_shrugging:


Additional note: The above also only has an effect on your own user account. If another user account were to have access to that folder, they would still get to see the thumbnails or icons, depending on their settings.

I was there already and cleared mkv and mp4, this are the most videos that i have, but that doesn’t change anything, related to this video icon or mimetypes (how ever that called).

Do you think i can only archive unknown file when i clear all Sub Menue’s under video?

No — if removing the application association doesn’t do it, then it won’t make a difference if you remove all the others.

The only other alternative that I can think of — but this is with the utmost certainty going to screw up your system, and I cannot tell you how to do it because I don’t know — is to mess with the MIME types. :man_shrugging:

1 Like

To change the icon right-click a file, Properties, select Change next to Open With, click on the icon, and select another icon such as the Unknown

1 Like

Silly question probably. But why bother encrypting a bunch of Movies?

1 Like