How can I make OpenGL use Nvidia driver?

Some Steam games won’t start and my guess is that it is related to bad graphic drivers. It seems like OpenGL uses Intel graphics instead of Nvidia for rendering. I’m not able to fix this (I broke my system when trying, hint: nvidia-xconfig). How can I make OpenGL use the Nvidia driver?

Output from glxinfo | grep OpenGL:

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.3.4
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.3.4
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.3.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Output from mhwd -la:

> All PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
       network-slmodem            2013.12.07                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI
     network-rt3562sta            2013.12.07                true            PCI
         network-r8168            2016.04.20                true            PCI
          video-voodoo            2017.03.12                true            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2021.12.18               false            PCI
      video-openchrome            2020.01.18                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2021.12.18               false            PCI
    video-nvidia-390xx            2021.12.18               false            PCI
       video-rendition            2020.01.18                true            PCI
          video-sisusb            2020.01.18                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
video-hybrid-amd-nvidia-prime            2021.12.18               false            PCI
            video-vesa            2017.03.12                true            PCI
          video-nvidia            2021.12.18               false            PCI
  video-virtualmachine            2021.07.26                true            PCI
              video-s3            2020.01.18                true            PCI


Warning: No USB configs found!

Output from mhwd -li:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI


Warning: No installed USB configs!

Any help would be awesome! :slight_smile:

Type in the launch options in the game on Steam

prime-run %command%

That would force the game to use the NVIDIA card OpenGL.

You can check if it works with

prime-run glxinfo | grep OpenGL
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.