How can I install [MediaTek.NTAMD64.10.0] MT7921 / MT7921K Driver

I am new to manjaro linux. My wifi is not working. How can I install [MediaTek.NTAMD64.10.0]
; MT7921 / MT7921K driver?

Hey there,

my AMD RZ608 WiFi (rebranded MediaTek MT7921K) started to work by using Kernel 5.16.14.

Thank you, that worked for me!

I have an MSI Laptop. Which has a wifi 6. Mediatek. I am new to Manjaro Linux. My laptop could not find any wifi connections. I can see that it doesn’t have any drivers. That might be the issue. Searched alot and tried alot. How can I solve this isse?

  Host: siam-modern14b5m Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64
    compiler: gcc v: 11.2.0 Desktop: KDE Plasma v: 5.24.3 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Micro-Star product: Modern 14 B5M v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-14DL v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: E14DLAMS.10A date: 10/21/2021
  ID-1: BAT1 charge: 28.0 Wh (74.5%) condition: 37.6/37.8 Wh (99.5%)
    volts: 12.7 min: 11.4 model: MSI BIF0_9 status: charging
  Info: 6-core model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
  Speed (MHz): avg: 1520 high: 2875 min/max: 1400/4056 boost: enabled
    cores: 1: 2875 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397
    9: 1397 10: 1397 11: 1397 12: 1397 bogomips: 50327
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Lucienne vendor: Micro-Star MSI driver: amdgpu v: kernel
    bus-ID: 03:00.0
  Device-2: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 3-4:2
  Display: wayland server: v: with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    gpu: amdgpu resolution: 1920x1080
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.28-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 03:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Micro-Star MSI
    driver: snd_rn_pci_acp3x v: kernel bus-ID: 03:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 03:00.6
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: no
  Device-1: MEDIATEK driver: N/A port: N/A bus-ID: 01:00.0
  Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-3:2
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 9.24 GiB (1.9%)
  ID-1: /dev/nvme0n1 vendor: Apacer model: AS2280P4 512GB size: 476.94 GiB
    temp: 39.9 C
  ID-1: / size: 459.43 GiB used: 9.24 GiB (2.0%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (RPM): N/A
  Processes: 276 Uptime: 3m Memory: 7.2 GiB used: 1.07 GiB (14.9%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1102
  Shell: Zsh v: 5.8.1 inxi: 3.3.14

Looking at the Windows drivers, it appears that the chip is [MediaTek.NTAMD64.10.0]
; MT7921 / MT7921K

This chipset appears to be supported in kernels newer than 5.12. Are you dual-booting Windows? If so, make certain that fastboot, hybrid boot and hibernation are disabled in your windows install. IOW, Windows should always be completely shutdown. It wouldn’t hurt to try another kernel as well.

Thanks for your reply. But I am not dual booting with windows. I am using Manjaro as my primary OS. Fastboot is disabled as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.