How can I install Budgie-SOLUS and create new MBR?

dear Phil,
How can i UNDO and delete all the changes that GRUB did in the Master Boot Record and make my HDD bootable as Legacy BIOS MBR again ?

i am quite old and i am not getting well with all the amount of Manjaro-updates, because they are very complicated for me, and i am a NOOB and should be spending more time outdoors in the nature to keep fit, than on the computer… :slight_smile:

i want to change to a clean installation of Budgie-SOLUS without Manjaro on it.

my laptop is Legacy BIOS MBR on a HDD.
it is NOT uefi.

10 hours i tried yesterday to install Solus, but the Master Boot Record of the HDD was not able to find the boot sector and always failed to boot.

then - in desparation - i even tried to install Ubunt and also my WinXP recovery cds: Nothing worked, HDD unbootable.

now i re-installed Manjaro again, and the laptop boots using GRUB without problem, and i am online here with it.

what do i have to do to UNDO and delete all the changes of GRUB in the Master Boot Record,
and make the HDD bootable as Legacy BIOS MBR again, in order to make a clean install of Budgie-SOLUS?

Budie-SOLUS is definitly NOT using GRUB.

i assume the MBR should be MBR/DOS and point to a NTFS formated HDD with Boot-FLAG on it?

Could you please explain detailed step by step (i am NOOB :slight_smile: ) what to do?

i am afraid that messing with the MBR could also completely destroy the HDD…
many thanks

mod. edit: moved to new topic

The other os (budgie) installer should have an option to do it. Maybe you did not click it.
The commands in the arch wiki (grub-install) should actually work on any linux os with grub like ubuntu.

There is no such thing as legacy mbr :slight_smile:
For windows xp and 7 the commands are fixmbr and fixboot from recovery console (you need a windows dvd/cd). There are many guides on the internet.

Here is some tutorial to remove the MBR: Linux Delete / Remove MBR - nixCraft Normally also Gparted can create a new partition table. You could also ask at the support forum why you might have this issue in your case @BTO Solus Forum

Thanks for your help!
Reading some of the comments in the tutorial link say they destroyed their HDD, and i am afraid of that :slight_smile:
I also tried to create a new partition table with Gparted before i installed SOLUS, but it also did not work: the GRUB on the Master Boot Record still pointed to the Manjaro-GRUB, and the Solus-system was not bootable because of swiping Manjaro.

GRUB seems to permanently remain on the Master Boot Record, letting no changes being applied, or other distributions installed.

Did you try to manually install the grub version of solus from a solus live ISO based on their wiki to your MBR?

I guess you have to get aquatinted with clr boot manager

sorry for late reply (i was at the car repair service in the meantime…)
No, i did not manually install the grub version of Solus.

i took the Solus live ISO and started the installer with the option “delete the hard drive”.
the Solus partitions were generated, but the laptop was not bootable anylonger because the Manjaro GRUB on the Master Boot Record remained the same and still pointed to the (not anylonger existing) Manjaro GRUB partition.

Then i tried first only with GPARTED to create a new partition table. After that Solus installer. Same results, not bootable.

Then i tried to format the HDD in NTFS, GPT, MBR/Dos, EFI GPT, EFI FAT-12-16-32 before starting installer. Always same results, not bootable.

i have no idea how i could get any further…

Try the following steps, exactly:

  1. Boot with a Linux Live installer.

  2. Use GParted to create a new MBR partition table:
    From ‘Device’ in the toolbar, select ‘Create new partition table’
    Make sure you select ‘msdos’ (BIOS/MBR).

  3. Do NOT create any partitions or attempt to format anything. Do not use GParted for anything other than creating the new msdos partition table. Any needed actions should be performed by the Solus installer as a part of installation.

  4. Save the newly created partition table.
    There should be a green tick when done.

  5. Close GParted, and shut down you computer, completely.

  6. If you have a second disk in your machine (apart from the one you wish to install Solus to), turn off the computer’s power (from the wall), and disconnect that second disk. When done, turn on the wall power again.
    If there is no second disk, ignore this step.

You should now have a clean slate.
The disk is ready for an BIOS/MBR-based OS (only).
Solus install should create partitions and perform any formatting needed; perhaps automatically, depending on the options you choose.
When you boot the Solus DVD/USB, it must boot in Legacy mode (BIOS/MBR).

  1. Boot with the Solus installer DVD/USB.
    Follow prompts and configuration steps to install Solus.

If this procedure fails to result in a bootable system:

a) You are likely doing something very wrong.
b) You possibly missed a step while setting it up.
c) Perhaps there is an issue with the ISO/DVD/USB installer.
d) A miriad of other possibilities.

  1. Contact Solus for further assistance. Help/Forum/Wiki etc.

I have nothing more to offer. Good luck.

The main point here is, normally nobody has to erase MBR, because on a bootable drive there has to be something there, and only one thing. So the process is always overwrite. If you cannot do it, there is something else very wrong going on. Purely erasing withouth writing anything there makes absolutely no sense.

Perhaps - perhaps not - it may be using either or depending on your system capability.

Solus leverages clr-boot-manager from the ClearLinux project to manage its boot process.
On legacy BIOS systems, clr-boot-manager will configure GRUB2 to properly boot your system.
On modern UEFI systems, clr-boot-manager will configure systemd-boot instead.
This means that any time we want to modify the boot process, clr-boot-manager will be involved.
Trying to modify the configurations manually may work temporarily, but will be overwritten eventually.
Boot Management | Solus Help Center

To remove the MBR is highly destructive so use with care.

Generate a disk list

lsblk -a

If your device has more than one disk - remove the second disk

Then make a note of the device name for the disk you want to use example /dev/nvme0n1 or /dev/sda

Erase the first 512MB data from the disk - this will remove any MBR, BIOS/GPT, partition table and EFI partition

  • this will destroy partition table
  • so you need to be absolute sure
  • there is no going back
  • there is no checking or validation
  • it is ultimate destruction

The command needs to executed as root (elevated permission or su)

  • adjust the command by removing the excess parts of highlighted text
  • leave only your device (e.g. sda,sdb,nvme0n1,mmcblk0)
  • double check before you hit Enter

dd if=/dev/zero of=/dev/{sda|nvme0n1} bs=1M count=512

Their wiki actually states they are using grub on mbr systems.

Solus stores their kernels and images in /usr/lib64/kernel, not in /boot.

If you started with a MBR-boot system, the solus installer should have installed grub. That’s what took place on my MBR-boot laptop. It then creates appropriate symlinks from the kernel location to /boot or /.

However, once you have a EFI partition, or the presence of GPT partition table, it will see it as UEFI and want to use clr-boot-manager as the bootloader.

My second solus install was a weird case because my multi-distro PC has MBR on the msdos partition table drive 1, but drive 2 is a large GPT drive for most of my distros. The Solus installer kept seeing it as a UEFI boot machine and couldn’t proceed (no EFI partition) with the installation.

So I installed the thing on a old laptop then used Gparted to copy the whole Solus partition to a partition on my multiboot PC. However, clr-boot-manager still sees it as a UEFI so doesn’t want to create the symlinks after every kernel update. Without those symlinks, updating grub in your controlling distro won’t detect the kernels since they are in a place normal grub doesn’t expect.

My solution was to do it myself - create generically-named symlinks from every new kernel and image.

That way, my custom grub entries can point to these generic names.

Since they update their kernels very often, I made a simple script to create the new links whenever that happens.

1 Like

Probably the OPs ongoing endeavors have left the HDD in such a state that only a low-level format might fix it; but that’s only speculation.

thank you for your advice and i followed your steps.
and i also respected the comments from Teo to not just erase all the info on the Master Boot Record myself to not damage the disk, and better overwrite the contents with new info.

i still could not install Solus because the Solus-installer always only created a GPT Partition Table on my MBR Master Boot Record. I assume this is the reason why my laptop is unbootable after that.

so i re-installed Manjaro-Mate again: the Manjaro-installer creates a MSDOS Partition Table and MBR-bootloader on the Master Boot Record. from there Manjaro boots into a GRUB without problem. everything works out of the box.

from this pure MBR condition as a starting point, i tried to install Solus again:
and again the Solus-installer created a GPT Partition Table and GPT-bootloader on the MBR Master Boot Record. again system unbootable.

again i re-installed Manjaro-Mate: the Manjaro-installer creates a MSDOS Partition Table and MBR-bootloader on the Master Boot Record out of the box. from there Manjaro boots into a GRUB without problem. everything works.

again tried to install Solus, but the installer again suggests to create GPT Partition table, and here i stopped my tries yesterday.

Manjaro and Solus are using the same Calamares installer.
i dont know why Manjaro produces an MBR bootable system out of the box, while Solus does not.

but my goal is to have a clean installation of Solus without Manjaro on my computer, because i am not getting well with all the huge amount of complicated Archlinux-updates

would you know how i could force the Solus-installer to create MSDOS partion table + bootloader?
maybe it needs some change in a .conf file of the installer?

Solus-Installer recognised MBR

Solus-installer summary: generate GPT-table on Bios/MBR

These questions you should really ask in a Solus forum and not here as it appears to be a Solus related issue. Could be that you have to boot the ISO install medium in BIOS mode. You could also use GParted to completely wipe the disk upfront and to create a msdos parted disk before you start the installer.

Personally, I would give the “Manuelle Partitionierung” a chance. :wink:

They don’t say that. They ran the command, it erased the partition table and they lost their data but the drive would be ready for a new install.

Two things to try; first lets try with the solus installer:

  • in solus installer click ‘Manuelle Partitionierung’, then
  • pick your drive
  • ‘create new ms-dos partion table’, then
  • create one large ext4 partition
  • install

If the solus installer fails to follow that (and I agree with @Wollie that this is possibly an issue with the solus installer) lets prepare the disk first by using gparted from manjaro’s live usb so that solus can use it’s ‘Ersetze eine Partition’ option since that should preserve the drive’s setup.

  • boot manjaro live usb
  • start gparted
  • pick your drive
  • on the ‘Device’ tab pick ‘New Partition Table’ >> ms-dos
  • create one large ext4 partition (sda)
  • apply changes, quit gparted, shut down
  • boot solus installer
  • pick ‘Ersetze eine Partition’
  • point solus to ‘sda’
  • install

Does your computer’s BIOS boot priority settings show that the preference is to boot a live USB as UEFI instead of MBR/legacy boot? [mine has those kinds of settings].

You have to make sure you are booting the Solus live ISO as MBR boot.

If you have already checked this, then I can’t help further. I had to install my Solus on another computer then copy the partition over, but in my case I have other distros (actually, Manjaro is controlling grub currently) on that computer which can use custom entries to boot into Solus.

Since you want to replace Manjaro completely with Solus (and are not co-existing), it seems strange that you aren’t asking these questions on the Solus forum.

I just installed Solus in a (4-core CPU) virtual machine, setup as BIOS/MBR. It created a GPT partition table, and installed as UEFI.

However, on the next attempt, Solus installed as BIOS/MBR;

The trick is to create an msdos partition table with GParted, before installing Solus. When the Solus installer finds this partition table, setup progresses as a BIO/MBR installation. If this is not done, or skipped, then the Solus installer continues as a UEFI/GPT installation.

This will hopefully solve your issue.

  1. Boot to the Solus Live environment.

  2. While in that environment, open GParted Partition Editor from the Menu…

  3. Create a new msdos partition table:

  • Choose: Device → Create Partition Table → Select msdos → Click Apply. Close GParted.
  1. Launch the Install System icon on the desktop, and start to setup your system.

  2. When you come to the Partitions section, the first option will be Replace a partition – Select this option, and click the first partition indicated under Select a partition to install on.

  3. Click Next and continue setting up your system.

When finished, remove the Solus DVD/USB and reboot your computer. If you followed these directions exactly, without any deviations, Solus should now be installed as BIOS/MBR.

Also, just to confirm, Solus does indeed install Grub (v2.05) on a BIOS/MBR system, and boots as expected.


Something I was going to mention.

On my Lenovo machines there are options such as “UEFI only”, “Legacy Only”, or you can set the priority so that it tries Legacy first, etc…

N.B. It may be possible to install Solus in BIOS (legacy) mode on a GPT disk, as it is with Manjaro (I have two machines set up this way and my housemate has a third.
You just need to create a small “BIOS_GRUB” partition (unformatted) right at the beginning of the disk and do a manual install from there.

I am not familiar with Solus at this time though so you’ll need to check their forum / documentation.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.