How can I give read and write permissions to a partition on fstab?

Hey, everyone!

I’m trying to add a disk to fstab in order to have read and write permissions. The disk (sda) has two partitions: sda1 for Backup, and sda2 for Timeshift; the former is formatted as NTFS and the latter as ext4. I’ve created a mount folder inside my user folder for the entire sda disk: /home/alejandro/mount/disks which has two more subfolders for each partition: backup for sda1 (~/mount/disks/backup) and timeshift for sda2 (~/mount/disks/timeshift). This is the line I’ve added to fstab for sda1:
UUID=44C27F65C27F5A5E /home/alejandro/mount/disks/backup ntfs defaults 0 0
After a system reboot, I still can’t create or delete a file in that partition. Should I have to change the defaults option in that line?

Thanks in advance!

The mount options for ntfs are different from those of a Linux-native filesystem. Either see… :arrow_down:

man mount

… which has a section on the mount options for ntfs, or read these tutorials… :arrow_down:


Thank you very much! I’ll check that info out!

A unix system, eg Manjaro or anyother Linux, won’t mount partitions with permissions that apply to a single user when using an entry in fstab.

So to be able to manupulate stuff on those mounted partitions you need to perform all actions as the root user.
That’s how unix filesystems operate.

You could in case of your “Backup” partition, use the following steps:

  1. Mount the partition anywhere you like.
  2. Allow access to anyone or your user account by doing only one of the below: (Not both commands after each other!)
    sudo setfacl -R o:rwX,d:o:rwX <your mount point>
    • This will make everything on your partition world-read-write which is dangerous from a unix point of view.
    sudo chown -R <your username> <your mount point>
    • This will change ownership of all files and directories to your user account, which is not advisable either in general, but acceptable in case of backups that store the actual contents inside a file which doesn’t matter who owns the backup file itself…

Anyhow Linux is not like M$ where anyone can do anything without proper authorization :wink:

1 Like

So, could I then put this on the console to have writing permissions? Obviously after mounting that partition.

sudo chown -R alejandro /home/alejandro/mount/disks/backup

If that backup partition does NOT contain single files from your system, who all have their own permissions as needed for proper functionality, then yes…

Disclaimer, that action is NON-REVERTABLE !

1 Like

It’s a NTFS partition which only contains personal files, not system ones… but it’s mounted inside my home folder. Does that matter or does can have any negative effect on the system?

I just went to Windows, opened up the backup partition (sda1), I did some normal stuff here and there, and rebooted the system onto Linux… now I have writing permissions!!! How is that possible if I did not make any changes?

If you have Fast Startup or Hybrid Sleep enabled in Windows, then Windows doesn’t properly shut down its filesystems, with as a result that the Linux kernel will upon booting see the Windows partition as damaged and will mount it read-only so as to prevent further damage.

1 Like

True!!! This had happened to me before but I didn’t remember until now thanks to you!!! I just have to disable the fast startup on Windows!!! Thanks a lot!!! :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.