How can I get ksysguard as a binary package back?

I’ve been using ksysguard for years since I switched from Windows to Manjaro in 2019 and 2020, but it seems to no longer be available as a binary package in any of the main repositories, nor the AUR.

Please don’t recommend other tools for now. I have tried a ton, including htop and Plasma System Monitor, and settled on ksysguard. I’ve also retried those other tools today and determined that I still want ksysguard. So, I’m only looking for how to get ksysguard back for now.

I say “as a binary package”, because the ksysguard-git AUR package pulls in a ton of -git package dependencies, including packages which conflict with non-git packages I have installed. So, even though I’m okay waiting through a long build process to get ksysguard once, I don’t want to have to switch to -git packages for a lot of the rest of my KDE packages and have long build processes and potentially incompatibilities and regressions often.

Thank you for any help! I appreciate this community.

1 Like

It is in the repository… Maybe you should change and update mirrors.

1 Like

ksysguard is in the Manjaro repository, as you can see here for both the Stable and Testing branches. However, if you are on Manjaro Unstable, then that one has Plasma 6 already, and ksysguard has been dropped in Plasma 6.

1 Like

You’re both right, and I should have mentioned this in my original post: I’m using the unstable repositories to improve compatibility with a few AUR tools and keep updated more closely with the Arch stable repositories. It has been removed from the unstable repositories, as far as I can tell.

What I’m looking for is how to get it back even with the acknowledgement that Arch has dropped ksysguard from Plasma 6.

You cannot get it back, because it’s no longer compatible.

The only option I see is ksysguard6-git from the AUR, but it’ll need to be built on your own local system.


This app is unmaintained and no longer released by the KDE community.

Which is probably why ksysguard6-git has to pull in a load of other stuff. It’s a hack. I’m afraid you’ll have to either deal with that or move on.

1 Like

Oh, ksysguard6-git does build without pulling in a ton of dependencies! I was able to build it and run it, and now my ksysguard command is back. I hadn’t tried it despite having seen it in the list because I’d assumed the situation would be the same as ksysguard-git. Thank you! This suits my needs.

I’m okay with it being an unmaintained hack. I just want to manage processes and the tool hasn’t changed in the last 5 years anyway. I appreciate the warning that I will need to deal with the burden of an unmaintained package in the future though. I’m hoping it will hold me over until there’s a well-maintained alternative in the ecosystem which suits my needs.

The replacement is mature enough. plasma-systemmonitor.
The problem with it is that its quite large and clunky in comparison to ksysguard.

It is more flexible and crashes often.

Never noticed crashing, but I dont have extra plugins and I dont just leave it running constantly as some folks tend to do.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.