How can I disable btusb (bluetooth) so it's not consuming power?

I’ve disabled bluetooth at the gnome level, at the systemd level. how do I permanently stop the device itself so I can save power?

  1.23 W    100.0%                      Device         Radio device: btusb
systemctl list-unit-files | grep blue
bluetooth-mesh.service                                disabled        disabled
bluetooth.service                                     disabled        disabled                                      static          -
                   description: Bluetooth wireless interface
                   product: AX201 Bluetooth
                   vendor: Intel Corp.
                   physical id: a
                   bus info: usb@1:a
                   version: 0.02
                   capabilities: bluetooth usb-2.01
                   configuration: driver=btusb maxpower=100mA speed=12Mbit/s
blacklist btusb
blacklist bluetooth

in /etc/modprobe.d/blacklist-mine.conf

Take a look at rfkill command line tool for enabling and disabling wireless devices.

man rfkill
rfkill --output-all

If you are not going to use the thing, might as well not even load the associated modules. We are talking about power saving after all.

well… I killed it, but that didn’t persist across reboots.

… of course not

read the next (and previous) post of @cscs

that list was insufficient, but I adapted it to the real (full) list of modules. I don’t love this solution since it’s not that friendly if I ever did want to use the hardware (it’s just so rare that I actually do/have, as the only bluetooth devices I have are my phone and a headset)

Who’s fault is this anyways? I feel that there’s a bug here that I turn off bluetooth (including, at IIRC systemd level) and yet it’s still eating power. I’m only assuming that blacklisting the mods makes it stop, I’m not actually certain that it turns the hardware off, vs just making the kernel unaware of the hardware. Of course, I’m also assuming that it can be turned off, or put into a lower power mode.

Then maybe you prefer this method;

(and/or other stuff on that page)

If you still temporary want to use Bluetooth, then i would create me my own .sh file and execute the rfkill command manually and put this file on my desktop.