How can I change the font for Telegram Desktop in manjaro gnome?

I want to change the font for telegram desktop client. because with the current font bangle texts are showing issues. I’ve already tried through the qt settings. but I failed.


this message comes after pressing the button “Information”
there is a error here. I don’t know what is this and why is it here. I just need to change the font for telegram desktop.

According to this article, you can’t change Telegram’s font without changing everything else. :man_shrugging:

@flibby.jibbit
i want to change that.
it’ll be okay to change everything else (other apps’ fonts)

It seems you may have conflicting things going there for the Qt5 Configuration Tool to work.

What is the output of:

echo $QT_QPA_PLATFORMTHEME

The default now is gnome (using QGnomePlatform) instead of qt5ct (Qt5 Configuration Tool ). Kvantum can be used with either, that hasn’t changed.

If you want to change it, add the following to ~/.profile and edit it for your preferences:

# Available options: gnome, kde, qt5ct
export QT_QPA_PLATFORMTHEME="<value>"
 
# Available styles: Adwaita-Dark, Adwaita, kvantum-dark, kvantum, Windows, Fusion
export QT_STYLE_OVERRIDE="<value>"
1 Like
qt5ct

Qt5 configuration tool , fonts , select the font size and style.

@Alif I tried the method described in the article I linked, but was not successful. :man_shrugging:

Ok
I will change the font for everything else. How can I do that in manjaro Gnome??
Everywhere I want to set Noto Sans Bengali font.