How can I change automount pont /run/media/user to /mnt?

When I click on a new device on Thunar, it mounts it on /run/media/user/[device], and it apears as device on Thunar, but when I mount it manually on /mnt/[device], it doesn’t appear on Thunar as device.
How can I change the automount point to /mnt, and what do I have to do to see the devices I manually mount on /mnt on Thunar?

This is because GTK based systems use gvfs (Gnome Virtual file System).

If you want to mount a device in a permanent way - you should avoid /mnt as this is designated temporary mount.

What appears in the leftmost pane of Thunar is what thunar recognizes as part of gvfs or when you use the x-gvfs-show mount option.

You can of course use whatever teminology suiting you best - but if you want to eliminate trouble you should use another structure distinct from the system.

1 Like