How am I breaking Plasma?

Twice recently I have broken Manjaro KDE Plasma and been unable to fix it. I’m sure the problem could have been easily fixed by someone with a better understanding of how everything works, but although I am a very enthusiastic user of Linux, I don’t have a deep understanding of how it works, and therefore I’m not good at fixing it.

And I cannot supply logs or anything, as I’m now on Popos and the relevant information has been removed from my home folder.

So I’m just asking a general question.

The first time was a few weeks ago and I think I’d just installed a large Manjaro update. I think the system would not shut down (hung on a stop job) so I used REISUB to restart.

And when I got back to the login screen, and put in my password, it just hung.

I was able to TTY in, so ended up removing all plasma related stuff from my home folder, and was then able to login.

On Friday I had to REISUB and the same thing happened, and this was with a fresh install of Manjaro KDE. Got back to login screen, put in password, and it just hung. It seems like using REISUB is the common denominator here. I normally enable REISUB in my /etc/default/grub, but looks like I need to stop doing that.

At this point I decided to switch away from KDE as everytime this happens it stops me getting any work done for many hours.

But on Friday, before I formatted my install and replaced it, I used timeshift to go back to a backup made earlier that day. It worked and I got to the login screen, but the same thing happened. It hung after I put in my password.

So it seems to me that it’s some configuration file, or files, in my home partition, and nothing to do with my root partition.

Has anyone any idea what’s going wrong? I know it’s asking a lot without any kind of logs, but I’m just looking for an idea of what might be happening.

Manjaro KDE Plasma is my preferred setup and I’ll go back to it soon, but if I’m going to do that I’d like to feel a bit more capable of dealing with this if it happens again.

A custom theme perhaps?

A longtime member @Aragorn, have experienced meltdown in the configuration files a couple of times - I am sure you can find the topics using the forum search engine.

Other than that I have no idea.

I am using Plasma and I very rarely have any issues - although I do use a lightly customised theme, I am also past the stage of heavily customising my desktop simply because the lesser I fiddle with theme the more stable my system is.


Could be anything. Hardware, theme, widget, misbehaving startup script or application, etc, etc.

We can’t guess what you’ve installed or changed.

1 Like

Then you DO have access to the logs.

You can also use a usb-stick with a installation iso and use manjaro-chroot.

Without any kind of information of WHY you have to REISUB there can only be wild speculation.

I received advice over themes on this very forum, the last time this happened.

Since then I clean installed Manjaro KDE, with a home folder that had had 100% of all configuration files removed (all that remained were my documents and pictures) and it’s been running with no themes installed by me. I’ve had it on breeze with not a single non-stock theming component downloaded or in existence in my home folder.

Thanks to all for your replies.

I’m aware that without any actual data (logs) from me, it’s a needle in a haystack situation.

I just wanted to ask in case something came up.

As it stands I’m reluctant to go back to KDE, as it was running on stock 2nd time round, and it broke, and I cannot even fix it with timeshift as the problem exists, I beliieve, somewhere in my home folder/partition.

Stop trying to customize it straight away. Just use it out of the box, get use to it, then slowly make changes.

That answer means “I do not want to know what is wrong, I rather just move to something completely different”, because if you ACTUALLY want to use KDE, you would check your logs and post them here so we might help you fix it because nothing with what you type is normal KDE/plasma behaviour. :upside_down_face:

It was stock everything. See two posts up. I neuked the install and every single thing in my home folder, and once I clean installed it I themed nothing.

My problem is that I run a small business, for which I need a working computer, and normally don’t have time to wait for replies. It’s faster to reinstall the OS or install another.On Friday night, when KDE broke, I had to get various documents completed and sent, so troubleshooting was out the window.

I would like to know what’s breaking the system. That’s why I posted here, I hoped I’d get lucky and find an easy answer.

A roling release distro might not be the best for you in this situation then.
You need something SUPER stable like RHEL or Ubuntu.
I suspect you do not want to loose money because of software problems and stability should be your main concern.

But to answer your question in your title:

How am I breaking Plasma?

Answer: Nobody can EVER tell you without you providing logs.

Feel free to mark this as the solution :white_check_mark: :person_shrugging:

Well, Manjaro KDE Plasma has been astonishingly stable for me. I switched 100% to Linux in early 2020 (deleted windows partition and will never go back). I ran Linux Mint for about 2 months, and then switched to Manjaro KDE, and it’s been rock solid for about 3 years up until recently. Nothing I did broke it. All updates went great. No problems ever.

Red Hat and Ubuntu I don’t fancy, for reasons most of you will know of. I have thought about moving to Debian.

And yes, I know. Without logs my post is pointless, but I was hoping some little thing might have popped up. You know those posts you stumble upon where someone says, “That happened to me, but after I deleted /home/user/.config/randomconfigfile.config, I was able to boot back in with no problems.” That’s the reason I created this post. Just in case that happened.

Anyway, thanks again to those who have replied. :+1:

this looks like a messed up update…

why did you had to use REISUB?

but without logs and your system info its hard to tell…
it could be nvidia related if you are using it…
it could be baloo related…
it could be kernel related…
you could have run out of RAM…

I used REISUB because the system was hung on shutdown.

No nvidia in this machine. I got a machine with ATI graphics because the driver is in the kernel.

I doubt I ran out of ram. This machine has 128gb of the stuff. :grinning:

Probably bad luck. It happens. :stuck_out_tongue:

Now that I like. And without logs from me, it’s about as close as anyone can get. :grinning:

In the future I’ll be better at linux problem solving, but I have a lot to learn first.

The first thing to test is what happens when you remove all the config:

First by trying out a new user, to see if it’s borked or if it’s just you.
mv ~/.config ~/.confOLD

Log out/in again and you should have a vanilla desktop.

If it’s good, then you can open Dolphin, 2 panes:
~/.config | ~/.confOLD`

Copy/move a folder or two back, logout/in and see if the bug came back.

Eventually, you import your entire config and isolate the issue.

A stop job is not a hang. There is usually a valid reason for a stop job to occur, and though it means waiting possibly several minutes, that’s exactly what you should do; no matter how inconvenient it may be.

Using REISUB, although effective when needed, is not the answer to all things. For that, you would need the number 42.

1 Like

Ben, thank you for this. That is a beautifully simple, and practical, thing I can do next time something like this happens to me.

And it’s not something I’d thought of. Not in the clear way you explain it anyway.

I have a directory on my computer called linux_knowledge. It has been steadily growing for 3 years. It’s full of text files with terminal commands and tips and procedures I need to keep on getting better with linux. What you’ve said is going into it. :+1:

Are .local and .cache much less likely to be involved in a problem like this? Most of the dotfiles I backup come from .config and .local/share, so I’ve always looked on these two folders as the important ones in terms of how my stuff works, but it sounds like .config is the main one for controlling how the DE works. Is that about right?

1 Like

Something worth looking at is Obsidian (there are others, Joplin too).

I have a folder called ‘Notes’ which appears as a nested/organised list of topics and subtopics in Obsidian. That’d make a nice folder inside your ‘linux’ folder.

I also have the firefox addon which downloads a web pages as a Markdown file, saving time when I want to get notes in, when sometimes it’s easier to edit out parts I don’t want than it is to copy and paste parts I do want.

All notes are easily linked and organised.

Are .local and .cache much less likely to be involved in a problem like this?

.cache not so much, but .local is possible.

If moving .config doesn’t work, then put it back and try something else.

So they’re mostly hidden, it’s worth keeping those in a nice folder (called 'hidden stuff maybe) in Dolphin.

Here’s the ‘application’ folder where you can create new launchers by simply copying an existing one and editing it. I made kcmshell5 launchers for individual settings items.

Some folders aren’t in the correct places - like ~/.mozilla (should be ~/.config/mozilla) so I don’t want to oversimplify, but the config folder is huge and covers maybe 99% of my bugs over the last few years.