Hot plugging no longer works after changing to vc4-fkms-v3d

I am runing mine RPi 4 as a main developement desktop. For that I use two monitors.
For some unknown reasons since three month ago mine second HDMI port will not detect monitor (within linux) unles hdmi_force_hotplug=1
was added to config.txt
Yesterday after using pacman -Syu mine mouse started laging and so based on multiple messages I have changed from dtoverlay=vc4-fkms-v3d to dtoverlay=vc4-kms-v3d that solved the mouse, but I have lost the monitor connected to a second hdmi port.
Computer starts on both displays, but as the kernel is loaded the second dysplay goes off.
Any ideas about either getting hotplug working again or howto use mouse with an old settings?
I have no problem with mine backup 1GB pi4 /which runs both displays without hotplug, but that is too slow and I cant get another pi any time soon.

I have found forum about it on a RPi bug tracker.

  1. With dtoverlay=vc4-kms-v3d set check to see the suitable setting for your display.

  2. Change dtoverlay=vc4-kms-v3d' to dtoverlay=vc4-fkms-v3d`

  3. Find which HDMI is your nonworking monitor connected to (if no monitor working use HDMI-A-1 )

  4. on /boot/cmdline.txt add inline in a first line
    replacing values for yours. Dont forget the ā€œDā€

  5. Center your screen using relevant menu on your monitor.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.