Horrible static noises with my microphone

So recently I installed Manjaro. Glad to be here. My first impression about Linux in general is very easy and welcoming thanks to Manjaro. So I didn’t notice it at first but now I found out that my laptop microphone (the default onboard one) wasn’t working. It produces this horrible static white noises that won’t go away.

After digging around on the forums I tried to installed some drivers in the Terminal doing these commands:

mhwd -d --pci

The result returned two Audio devices:

PCI 300.1: 0403 Audio device
  SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:03:00.1
  SysFS BusID: 0000:03:00.1
  Hardware Class: sound
  Model: "ATI Audio device"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x1637 
  SubVendor: pci 0x1002 "ATI Technologies Inc"
  SubDevice: pci 0x1637 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfe788000-0xfe78bfff (rw,non-prefetchable)
  IRQ: 85 (541 events)
  Module Alias: "pci:v00001002d00001637sv00001002sd00001637bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Attached to: #20 (PCI bridge)


PCI 300.6: 0403 Audio device
  SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:03:00.6
  SysFS BusID: 0000:03:00.6
  Hardware Class: sound
  Model: "AMD Family 17h (Models 10h-1fh) HD Audio Controller"
  Vendor: pci 0x1022 "AMD"
  Device: pci 0x15e3 "Family 17h (Models 10h-1fh) HD Audio Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x1c0e 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfe780000-0xfe787fff (rw,non-prefetchable)
  IRQ: 86 (4505 events)
  Module Alias: "pci:v00001022d000015E3sv00001043sd00001C0Ebc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Attached to: #20 (PCI bridge)

When I tried to install new driver (I thought because if I update the driver it will work) the result came back as:

sudo mhwd -a pci free 0403                                       ✔ 
Warning: No config found for device: 0000:03:00.1 (0403:1002:1637) Multimedia controller ATI Technologies Inc 
Warning: No config found for device: 0000:03:00.6 (0403:1022:15e3) Multimedia controller AMD Family 17h (Models 10h-1fh) HD Audio Controller

How should I fix this?

My neofetch:

OS: Manjaro Linux x86_64 
Kernel: 5.15.12-1-MANJARO 
Shell: zsh 5.8 
Resolution: 1920x1080 
DE: GNOME 41.2 
WM: Mutter 
CPU: AMD Ryzen 5 4500U with Radeon Graphics (6)  
GPU: AMD ATI 03:00.0 Renoir 
Memory: 2804MiB / 7427MiB 

Appreciate the help.

mod. edit: objectified thread title

There are other topics on “microphone static noise” Take a look at them . Next time search before you ask .:slightly_smiling_face:

Have you excluded the hardware by testing the mic with an alternative OS?

1 Like

Based on vendor & device ID codes in OP, system is probably:

  • VivoBook X421IA_M433IA with 4th generation Ryzen CPU
  • Realtek ALC256 onboard audio
  • Dual internal digital microphone (Cortana support) DMIC
  • Stereo speakers
  • Headphone/Headset/Microphone jack

Asus online support shows 2 audio drivers for proprietary OS

  • Realtek Audio Driver for analog audio - speakers and headset jack
  • AMD ACP Driver for the DMIC and onboard audio processing (ICEpower®)

Data posted so far is only showing snd_hda_intel driver in use
I would expect system should load AMD Audio Co-Processor driver snd_rn_pci_acp3x to support the DMIC
But if only snd_hda_intel is available, ALSA is probably mis-detecting one of the digital microphones as a legacy analog microphone
Audio capture from one microphone would probably sound like a laptop from >10 years ago (at best)

I suggest you check if system has latest BIOS Version 312

If the DMIC is still not detected and working as expected with latest BIOS, please post more information about ALSA detection of devices

sudo alsa-info.sh --upload

Hello there again. My BIOS update has been completed. I did what you asked and here is my ALSA-INFO link:


I can confirm that the microphone is still very noisy and staticly. It can pickup my voice now unlike before however there is still quite a lot of static.

I’m waiting for further instruction from you.

Edit: For more information, I recently try to use a pair of Bluetooth headphones. When I pair it with the laptop however and switches the input device from the internal one of the laptop to the Bluetooth one, the output mix of the bluetooth audio changes from Stereo to Mono. I don’t know what caused this but hopefully this is something to give you further clues.