Horizontal Flipping of the Camera

So I’m trying to use the webcam on a Framework laptop. I tried to use V4l2-utils and ffmpeg to create a virtual camera using the command

ffmpeg -f v4l2 -i /dev/video0  -vf "hflip,format=yuv420p" -f v4l2 /dev/video2

but the framerate is about 5 fps. I tried to look at flipping the camera at the driver using v4l2-ctl but the driver does not seem to support flipping the camera.

Output of v4l2-ctl -L:

 brightness 0x00980900 (int)    : min=-64 max=64 step=1 default=0 value=0
   contrast 0x00980901 (int)    : min=0 max=95 step=1 default=0 value=0
 saturation 0x00980902 (int)    : min=0 max=100 step=1 default=64 value=64
        hue 0x00980903 (int)    : min=-2000 max=2000 step=1 default=0 value=0
white_balance_temperature_auto 0x0098090c (bool)   : default=1 value=1
      gamma 0x00980910 (int)    : min=100 max=300 step=1 default=100 value=100
power_line_frequency 0x00980918 (menu)   : min=0 max=2 default=2 value=2 (60 Hz)
				0: Disabled
				1: 50 Hz
				2: 60 Hz
white_balance_temperature 0x0098091a (int)    : min=2800 max=6500 step=10 default=4600 value=4600 flags=inactive
  sharpness 0x0098091b (int)    : min=1 max=7 step=1 default=2 value=2
backlight_compensation 0x0098091c (int)    : min=0 max=3 step=1 default=3 value=3
exposure_auto 0x009a0901 (menu)   : min=0 max=3 default=3 value=3 (Aperture Priority Mode)
				1: Manual Mode
				3: Aperture Priority Mode
exposure_absolute 0x009a0902 (int)    : min=10 max=625 step=1 default=156 value=156 flags=inactive
exposure_auto_priority 0x009a0903 (bool)   : default=0 value=1

Output of inxi -Faazy:

  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a90fb03b-1c36-4d87-9e6a-38fe301f7c12 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Console: pty pts/3 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Framework product: Laptop v: AA serial: <filter>
  Mobo: Framework model: FRANBMCP0A v: AA serial: <filter> UEFI: INSYDE
    v: 03.06 date: 10/18/2021
  ID-1: BAT1 charge: 6.5 Wh (12.2%) condition: 53.4/55.0 Wh (97.1%)
    volts: 15.7 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: Charging
  Info: model: 11th Gen Intel Core i5-1135G7 socket: U3E1 bits: 64
    type: MT MCP arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0x88
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 784 high: 900 min/max: 400/4200 base/boost: 2400/4200
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 741 2: 845 3: 688 4: 900 5: 543 6: 838 7: 857
    8: 866 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Realtek Laptop Camera type: USB driver: uvcvideo bus-ID: 3-7:7
    chip-ID: 0bda:5634 class-ID: 0e02 serial: <filter>
  Display: server: X.org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    bus-ID: aa:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp170s0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 101.21 GiB (10.9%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS100T1X0E-00AFY0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 614600WD temp: 40.9 C scheme: GPT
  SMART: yes health: PASSED on: 74 hrs cycles: 65
    read-units: 750,503 [384 GB] written-units: 998,274 [511 GB]
  ID-1: / raw-size: 892.16 GiB size: 877.15 GiB (98.32%)
    used: 100.75 GiB (11.5%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.18 GiB used: 475.1 MiB (1.4%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 45.8 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 305 Uptime: 23h 30m wakeups: 25717 Memory: 15.42 GiB
  used: 4.93 GiB (32.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1403 pacman: 1400 lib: 374 flatpak: 0
  snap: 3 Shell: Zsh (sudo) v: 5.8 running-in: konsole inxi: 3.3.12

Any suggestions on what to do next?