Hmm. We’re having trouble finding that site

Yesterday I was having trouble reaching google and now today I can’t reach Facebook too but all these websites runs perfectly fine in my android and only through VPN I can access both sites in my pc.

I tried accessing different websites like YouTube, discord, twitter and anime sites which works

Hi @saa_hossen, and welcome!

This sounds like a routing and/or DNS problem. Since you mentioned a VPN, it is likely that your routing table got messed up somehow.

Please post the output of

ip route



Run, and post the outputs of both when you ar e connected to the VPN and not.


:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.


This sounds like a DNS issue. Try changing DNS providers e.g. OpenDNS :
If you are using a router, try connecting directly to the modem to rule out a faulty router configuration.

Thank you for responding so fast…

ip route with VPN : via dev tun0 
default via dev enp6s0 proto dhcp src metric 100 dev tun0 proto kernel scope link src via dev enp6s0 via dev tun0 dev enp6s0 proto kernel scope link src metric 100 

ip route without VPN on :

default via dev enp6s0 proto dhcp src metric 100 dev enp6s0 proto kernel scope link src metric 100 

That could actually be one of the reason because a day prior my roommate updated the router firmware

Theorectically, it should be fine.

And it doesn’t look like a routing problem

Please provide the output of:

cat /etc/resolv.conf
1 Like

Some VPN’s do not just forward your traffic - they advertize some “additional privacy” features …
That can only work if they, with the help of their own DNS server, block out certain things.

So, use one of their alternative nameservers, or even one of your own choice and make sure those “additional features” are not getting into your way.

The way I understand is that it works with VPN.
The VPN provider probably pushes DNS.

So I would think something is wrong with ISP DNS server or the router update borked something…

My 2c.

Sorry for suddenly going offline. I had to get something from the market
This is the output I got

# Generated by resolvconf

I’m using it for a very long time. I had not faced anything like this before and the way I see it, it should’ve been fixed after hard resetting the router, but it didn’t

Please provide the output of:

ping -c 4

(Because from what I understand, that might not work, seeing as the 10.x.x.x IP range is private and looks like it could have been because of the VPN.)

… doesn’t imply that you should keep using it :grimacing:
use a different one

I don’t know how to check it - ping is not the right tool, it seems.

dig returns this:


; <<>> DiG 9.18.12-0ubuntu0.22.04.2-Ubuntu <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 50546
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;			IN	A

.			86398	IN	SOA 2023081200 1800 900 604800 86400

;; Query time: 88 msec
;; WHEN: Sat Aug 12 09:38:50 CEST 2023
;; MSG SIZE  rcvd: 116

I can’t interpret this result - looks strange.
I have dnsmasq running for caching dns requests.

JUST thought of this, that :point_up: doesn’t look like a valid IP address anyway. Looks more like some kind of broadcast-ish IP range, thingie…


Indeed, both ping and dig fails:

$ ping -c 4
PING ( type `Ctrl-C` to abort
───────── ping statistics ─────────
PACKET STATISTICS: 4 transmitted => 0 received (100% loss)
ROUND TRIP: min=0s avg=0s max=0s stddev=0s

$ dig
;; Query time: 13 msec
;; WHEN: Sat Aug 12 09:47:34 SAST 2023
;; MSG SIZE  rcvd: 116

So something is funky here…where did you get that DNS server from, how did you set it, and does it stay after a restart?

This shows that, without VPN, you use the default DNS server of the provider.
(your computer refers to the router - and it uses the providers DNS)

You can change that so that you use another one of your choice, independent of what the router gives you.

In NetworkManager settings, under IPv4 settings tab, select “automatic (DHCP), addresses only”
and below, in the DNS server field, put one or two of your own choice
(I have, there, simply because I remembered them and they are easy to type - and because they work, of course)

Many vpn providers assume a system using systemd-resolved - but Manjaro uses openresolv.

The result of my troubleshooting of NordVPN issues on Manjaro → [root tip] [How To] NordVPN on Manjaro

TL:DR the following set of commands will

  1. remove openresolv
  2. start and enable systemd-resolved
  3. backup your resolv.conf
  4. create a symlink to stub-resolv used by systemd resolver
sudo pacman -Rns openresolv
sudo systemctl enable --now systemd-resolved
sudo mv /etc/resolv.conf /etc/resolv.conf.bak
sudo ln -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf

Reboot your system to ensure the changes are reflected properly.