High CPU usage while gaming

Hello, I’m satisfied with Manjaro. Basically I got no problem but after I try gaming I got freezes over and over again no matter what kind of game is new/old.

Monitoring Result


I tried install recomended Kernel but CPU is getting high and high…
IDK if its ok but Swap got 0…

System Info
  • System:
    Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/vmlinuz-5.10-x86_64
    root=UUID=1e481acc-b0ec-4a3c-9b45-819e41715870 rw quiet apparmor=1
    security=apparmor resume=UUID=128ff269-2717-44d9-ab16-25225fa22443
    Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux

  • Machine:
    Type: Desktop Mobo: ASUSTeK model: H61M-K v: Rev X.0x serial:
    BIOS: American Megatrends v: 0801 date: 07/21/2014

  • CPU:
    Info: Quad Core model: Intel Core i5-2500 bits: 64 type: MCP
    arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
    cache: L2: 6 MiB
    flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26350
    Speed: 1810 MHz min/max: 1600/3700 MHz Core speeds (MHz): 1: 1810 2: 1799
    3: 1721 4: 1729
    Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
    Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
    Type: mds mitigation: Clear CPU buffers; SMT disabled
    Type: meltdown mitigation: PTI
    Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
    Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
    Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
    Type: srbds status: Not affected
    Type: tsx_async_abort status: Not affected

  • Graphics:
    Device-1: NVIDIA GK107 [GeForce GTX 650] vendor: Micro-Star MSI
    driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:0fc6 class-ID: 0300
    Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
    loaded: nvidia display-ID: :0 screens: 1
    Screen-1: 0 s-res: 1920x1080 s-dpi: 103 s-size: 473x261mm (18.6x10.3")
    s-diag: 540mm (21.3")
    Monitor-1: VGA-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6")
    diag: 546mm (21.5")
    OpenGL: renderer: NVIDIA GeForce GTX 650/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01
    direct render: Yes

  • Drives:
    Local Storage: total: 465.76 GiB used: 82.29 GiB (17.7%)
    SMART Message: Unable to run smartctl. Root privileges required.
    ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HD502HJ size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD
    rpm: 7200 serial: rev: 00E4 scheme: MBR

Maybe I have to set High Performance in Batery but IDK how to do this…

Sorry for my bad English.

Try to launch your games using gamemode, if it is Steam games it is easy, install gamemode then after that you need to go to your game properties in Steam, and in the Launch Options, you write exactly that:

gamemoderun %command%

Here is Game Mode wiki page to help configuring it Gamemode - ArchWiki

Unfortunately, it was ineffective. Perhaps the issue is caused by my CPU or GPU. I’m not sure how to check/test my GPU/CPU to see whether it’s working properly.

Are you trying to run native or Windows games through Proton? And which games are we talking about?

I tried all of the native games, but the outcome was the same.Those games need a minimum requirement like 2GB of RAM, etc… I played those games without any problems in the old days, but not on Linux. Well, it was 6-8 months ago, so I can’t say for certain if I was able to run those games smoothly in Windows. Right now I tried limiting CPU. Above 90 I got a freeze, but after finding the perfect percentage, which was 85%, everything went well, but I got one-third FPS. I can’t even do some basic stuff no matter if it is action or not. But now I know the CPU is a problem, but I don’t know how to fix that. The question is, can I fix it in the OS? or I have to buy a new one. I want to try setting up the battery as a high-performance one, but I have no clue how to do this. I may be able to fix that problem, so I will give it a shot.

That doesn’t mean the CPU is the problem to me.

What processes are running and using the CPU when you have issues?

From me, it’s the only game. The rest is from the root.