High CPU Usage: Process with Changing PID

Hello Manjaro community,

I’ve encountered an issue on my Manjaro Linux system where a process with a constantly changing PID is causing high CPU usage at constant intervals. After some investigation, I’ve observed that the process runs the command:

/usr/bin/ps ax -weo pid,rssipmem,vsize,uname:50,pcpu,start_time,state,groupinice,cputime,session,cmd --no-headings

This process consumes 100% CPU at times and then disappears, only to respawn with a different PID later withing seconds. This behavior has been quite disruptive to my system’s performance.

Note: The process does not show up on “top” or “htop” it only shows up while looking through “Stacer”

I’ve tried running a backtrace using gdb, but since the PID keeps changing, it’s challenging to pinpoint the root cause of the issue.

Here’s what I’ve tried so far:

  • Using pgrep to dynamically identify the PID of the process.
  • Running gdb with the identified PID to gather a backtrace.

However, I haven’t been successful in identifying the cause of this mysterious process.

I would greatly appreciate any insights or suggestions from the community on how to further diagnose and resolve this issue or how I can reduce my CPU usage overall. Additionally, if anyone has encountered a similar problem or has any tips on debugging high CPU usage caused by processes with changing PIDs, please share your experiences.

Thank you in advance for your help!

System Information:

  • Operating System: Manjaro Linux x86_64
  • Kernel: 6.6.19-1-MANJARO
  • Desktop Environment: Xfce 4.18
  • CPU: Intel i3-2120 (4) @ 3.300GHz
  • GPU: NVIDIA GeForce 8400 GS Rev. 2

Welcome to the forum! :vulcan_salute:

It’s probably a system monitor widget of some sorts that you have. The command ps lists running processes. See its man page… :point_down:

man ps

Nothing nefarious going on there so far. Now, if you were experiencing performance issues, then that would be whole other matter. :wink:

It is Stacer that is running that command… :facepalm:


This post didn’t exist. Shh (thank you so much for answering my braindead question :pray:)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.