High CPU usage on htop but no apps using cpu

Hi all,

I have recently reinstalled manjaro linux and I noticed the fans blowing away, even though I was not running any app.

htop shows high cpu usage even though no app is using the cpu to that level. it seems to be the kernel, but even with kernel threads enabled on htop i can’t see anything that would justify the usage.

Here is some more info on pastebin:

Can somebody help me understand what is going on here?

Thank you!

Two things i think about:

  • high IO: file read/write does use CPU
  • unused GPU: using the wrong GPU driver might solicit the CPU instead for screen rendering
1 Like

It is not just Kernel threads. Like @maycne.sonahoz wrote, IOwait and other Kernel interrupts listed in red, since the status bar is “kernel time” usage.

If it is a problem with IOwait, you might want to check that your SSD is healthy. It is sometimes a indication that there is something wrong with it or there is a problem with the filesystem, or it is just slow.

1 Like

I think I found the problem but I don’t really understand the impact of the solution.

Basically I used the command grep . -r /sys/firmware/acpi/interrupts/ as seen on How to handle cpu interrupts that causes high cpu usage , since it described a problem exactly like mine.

I found out that one of the interrupts had strange values (others were 0):
/sys/firmware/acpi/interrupts/gpe6E: 8565531 EN STS enabled unmasked.

I executed echo "disable" > /sys/firmware/acpi/interrupts/gpe6E as root and indeed it worked!
I have got massive improvements in htop:

But I want to know, does anybody know if there any side effects to disabling this interrupt? Is there a better way of doing this?

Hi @jpns05 , I’m the one who made the post you cited about the high cpu usage!
There’s no disadvantages or “long term” problems that this solution will cause, that I have experienced at least.

Funny thing, I also had windows 10 on that laptop and it presented a very similar problem with cpu usage, but I never tried to fix it on windows.
That’s the main reason I was seen such good performance on Linux compared to windows probably…

If you have created a systemd file to disable those pesky interrupts at boot I advice you to keep a copy of it on a USB disk/external HDD, because eventually you’re gonna reinstall the OS, and you since will have forgotten the steps to solve this problem XD
Happened to me a few times so I just save the file somewhere and I don’t have to think about it!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.