High cpu usage eventhough no apps are running

I just freshly installed manjaro KDE and system is upto date, but CPU usage is high even with just top running.

System Info:

System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.13-x86_64 root=UUID=ce5c9dc7-ebec-4cdd-8cc8-eb0db466960f rw
           rootflags=subvol=@ quiet apparmor=1 security=apparmor udev.log_priority=3
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 serial: <filter>
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.15.0 date: 06/16/2021
Battery:   ID-1: BAT0 charge: 16.3 Wh (45.0%) condition: 36.2/41.4 Wh (87.3%) volts: 14.4 min: 14.8
           model: LGC-LGC2.80 DELL 7PY0D0A type: Li-ion serial: <filter> status: Discharging
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6
           model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607
           Speed: 798 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 798 2: 800 3: 800 4: 800
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916
           class-ID: 0300
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: amdgpu
           v: kernel alternate: radeon bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:5769 class-ID: 0e02
           serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati,modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
           Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus-ID: 02:00.0 chip-ID: 8086:3165 class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000
           bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200
           IF: enp3s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:5 chip-ID: 8087:0a2a
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: see --recommends
Drives:    Local Storage: total: 931.51 GiB used: 196.64 GiB (21.1%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT
Partition: ID-1: / raw-size: 100.1 GiB size: 100.1 GiB (100.00%) used: 14.52 GiB (14.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
           ID-2: /boot/efi raw-size: 250.2 MiB size: 246.3 MiB (98.45%) used: 554 KiB (0.2%) fs: vfat dev: /dev/sda3
           maj-min: 8:3
           ID-3: /home raw-size: 831.17 GiB size: 831.17 GiB (100.00%) used: 182.12 GiB (21.9%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-4: /var/log raw-size: 100.1 GiB size: 100.1 GiB (100.00%) used: 14.52 GiB (14.5%) fs: btrfs dev: /dev/sda1
           maj-min: 8:1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 51.0 C mobo: 49.0 C gpu: amdgpu temp: 49.0 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 236 Uptime: 3h 8m wakeups: 3 Memory: 7.64 GiB used: 2.14 GiB (28.0%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1238 lib: 357 flatpak: 0 Shell: Bash v: 5.1.8
           running-in: konsole inxi: 3.3.07

CPU usage from Ksysguard:

CPU usage from top:

if you notice load average is always above 50%, and as I observed Process called kworker and kio are those using high cpu. (19%- 46%)

In auto-cpufreq (I was just running terminal):

-

                        "auto-cpufreq" refresh in: 1
                Executed on: October 13 (Wednesday) - 12:45:20

-------------------------------------------------------------------------------

Linux distro: Manjaro Linux 21.1.5 Pahvo
Linux kernel: 5.13.19-2-MANJARO
Processor: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Cores: 4
Architecture: x86_64
Driver: intel_pstate

------------------------------ Current CPU stats ------------------------------

CPU max frequency: 2500 MHz
CPU min frequency: 400 MHz

Core    Usage   Temperature     Frequency
CPU0:     2.0%     53 °C     2700 MHz
CPU1:    62.6%     51 °C     2700 MHz
CPU2:     2.0%     53 °C     1761 MHz
CPU3:     4.0%     51 °C     2700 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: discharging

Setting to use: "powersave" governor

Total CPU usage: 1.2 %
Total system load: 1.92
Average temp. of all cores: 52.0 °C

High CPU load
setting turbo boost: off

-------------------------------------------------------------------------------

Maybe it is indexing your files? You apparently have hundreds of Giga used, that’s probably that. Does it happen if you disable file indexing from System Settings? You can also do that from terminal

balooctl disable

Maybe it would be a good idea for the administrators of manjaro-kde to disable this service at the initial installation and stay at the user’s discretion whether to activate it or not.

Little by little I see that it is copying from the mistakes made by windows.

That’s a default KDE service for its file manager Dolphin, I don’t like it but it is what it is. Disabling it by default may not be a good option for a default installation.

On the other hand on a default installation the home folder is not 200GB (like here for this user) so here is the culprit, if the issue is baloo’s indexing, it needs to generate a huge index.

Personally I disable baloo and can still search (from the default search in the file manager, or with other tools like Kfind), nowadays with SSD it is really fast anyway.

This might be relevant: https://bugzilla.kernel.org/show_bug.cgi?id=212185
Basically I switched back to 5.10 while this being solved, however latest 5.14 should have the fix already.