Hibernation problem

Hello everybody! I have some hibernation problems on my laptop. I’m using swapfile, and I think that problem with it. When I turn on the computer, it starts a fresh start. What could be the problem?

Here’s my inxi -Fxz:

  Kernel: 5.11.22-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: GNOME 40.3 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: ASUSTeK product: ZenBook UX434DA_UM433DA v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: UX434DA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX434DA_UM433DA.307 date: 12/09/2020 
  ID-1: BAT0 charge: 5.1 Wh (11.8%) condition: 43.3/50.0 Wh (86.5%) 
  volts: 11.9 min: 11.9 model: ASUSTeK ASUS Battery status: Discharging 
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen rev: 1 cache: L2: 2 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33550 
  Speed: 1222 MHz max: 1400 MHz boost: enabled Core speeds (MHz): 1: 1222 
  2: 1222 3: 1360 4: 1252 5: 1221 6: 1221 7: 1227 8: 1222 
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus-ID: 03:00.0 
  Device-2: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 3-2:3 
  Display: wayland server: X.Org compositor: gnome-shell driver: 
  loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 
  5.11.22-2-MANJARO LLVM 12.0.0) 
  v: 4.6 Mesa 21.1.4 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.1 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: snd_pci_acp3x v: kernel bus-ID: 03:00.5 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.6 
  Sound Server-1: ALSA v: k5.11.22-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus-ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-4:2 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Local Storage: total: 238.47 GiB used: 58.78 GiB (24.6%) 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNG-8310A 
  size: 238.47 GiB temp: 38.9 C 
  ID-1: / size: 233.38 GiB used: 58.78 GiB (25.2%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-1: swap-1 type: file size: 12 GiB used: 0 KiB (0.0%) file: /swapfile 
  System Temperatures: cpu: 54.4 C mobo: 54.0 C gpu: amdgpu temp: 54.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 293 Uptime: 5m Memory: 5.81 GiB used: 2.11 GiB (36.3%) 
  Init: systemd Compilers: gcc: 11.1.0 Packages: 1319 Shell: Zsh v: 5.8 
  inxi: 3.3.05 

Swap info:

/swapfile file  12G   0B  100

In my grub file I got this:

GRUB_CMDLINE_LINUX_DEFAULT="resume=088ef75f-4872-4f47-8e9d-ceb0144a7e82 resume_offset=17661952 quiet splash apparmor=1 security=apparmor udev.log_priority=3"

And this line in mkinitcpio.conf:

HOOKS="base udev resume autodetect modconf block keyboard keymap plymouth filesystems fsck"

Am I missing smth? Thanks in advance!



Just tried it. But it won’t work because I am using a swapfile. It is also necessary, in addition to the UUID of the section, to indicate the offset, as I understand it.

yes add resume_offset but nothing change for resume : use resume=UUID= if you pass uuid partition

1 Like

Kernel 5.11 is no longer supported, switch to another one, for example 5.10 LTS. After the change, update your system.

Have you considered all details of the wiki:
Power management/Suspend and hibernate - ArchWiki


resume should go after block if I remember it correctly. On my system it is right before the filesysmes btw.
Also make sure that 088ef75f-4872-4f47-8e9d-ceb0144a7e82 is the UUID of your root partition.
After editing mkinitcpio.conf do sudo mkinitcpio -P to regenerate initrds.

And re-read @megavolt’s message once again. It was meant to advise you that you missed UUID= part in GRUB_CMDLINE_LINUX_DEFAULT string when assigning value to resume parameter.


Yes, I got what u wanted to say! LMAO, I forgot to write UUID after resume!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.