Hibernation issues

I am a noob. Ill go ahead and get that out there. Hibernation has not been working since I installed manjaro Kde Plasma Kernel 5.13.13 this past weekend. It is installed on a 500 Gb external SSD. I installed it using the swap file option.

Once it goes into Hibernation I just get a black screen when I open the computer or click any buttons. I’ve been reading up on some hibernation issues with others. I have noticed that my swapfile is under sized. I have 7.5 Gib of RAM.

grep SwapTotal /proc/meminfo
SwapTotal: 524284 kB
   ~  swapon
/swapfile file 512M 0B -2

I tried using a tutorial on increaing swapfile size from here How to increase the size of your swapfile | ArcoLinux .

But when I tried, the size was unchanged and I got this message.

mkswap: /swapfile: warning: wiping old swap signature.
Setting up swapspace version 1, size = 512 MiB (536866816 bytes)
no label, UUID=aec9d95a-0d37-4af1-9f9b-9964e62427e1

Any help is much appreciated.

What exactly did you try? Maybe the Archwiki has a better explanation Swap - ArchWiki

I guess, you created a new swap file but didn’t enable the system to use it actually.

I found the mistake. I had written
sudo dd if=/dev/zero of=/swafile bs=1M count=4096 status=progress → example (I changed count)

swafile instead of swapfile. I found the new file, removed and started over. I went by the recommended swapfile space for 8G RAM and now have 11G (based on the table provided by swap article on wiki manjaro) for swapfile. Maybe Hibernate will work now ??

Only semiconductor gods know right?!
After removing old swap file and adding a new one as per @mithrial link, follow this procedure.

Now that the swapfile is larger I am able to resume after closing my laptop. Hibernation appears to be working now. Thank you all for your responses.

Well not hibernation still doesn’t work if my computer isn’t plugged in. Would there by a power management setting that needs to be adjusted?