Hibernation device not found after fresh installation with latest images

I installed official XFCE manjaro (manjaro-xfce-21.2.6-220416-linux515.iso) with disc encryption and hibernation. Unfortunately after first reboot I got the following error message:

Device does not exist or access denied.
ERROR: resume: hibernation device '/dev/mapper/luks-....' not found

I was able to reproduce it also with latest official KDE (manjaro-kde-21.2.6-220416-linux515.iso) on my virtualbox.
So it seems this is a general issue with the latest images when enabling disc encryption and hibernation.

I didn’t found a solution for it searching through the forum or the internet.

I workarounded the issue by using an older image (manjaro-xfce-21.1.6-211017-linux513.iso), with this the hibernation is working well.

Attached a screenshot from the error message and console output from ‘lsblk’:


lsblk

output from crypttab, default grub, fstab:



Hello, I openend topic Hibernation device not found after fresh installation with latest images and it seems nobody can help.
Therefore I would like to ask where can I open a bug ticket for manjaro so that a manjaro developer can look into it?
Since everybody can reproduce the issue with the latest images, it would make sense to open a bug ticket.

Thank you in advance :slight_smile:

Hi @fl4bn4t,

I do not use LUKS or hibernation, but I have seen quite a lot of the errors as in you post on here. You should try the search function sometime.

Please see:

It seems to me there is something amiss in the etc/default/grub file. Specifically with the line containing GRUB_CMDLINE_LINUX_DEFAULT=:

Also, check out:

https://wiki.archlinux.org/title/Dm-crypt/Swap_encryption

Hope you manage!

1 Like

Thank you for the reply @Mirdarthos , I already searched and found these links, most of them using hibernation with btrfs, which I do not.

Also, I am not searching for a ‘solution’, but want to open a bug ticket, since someone should fix the issue upstream, so that a fresh installation of manjaro with encryption and hibernation didn’t result in hibernation error messages.

well i think you’re expecting too much “service”. manjaro is an arch-based rolling-release and therefore it’s a basic rule to deal with problems on yourself. you need the spirit to live, deal and use trial and error.

1 Like

If that is so - then it is likely an issue with the Calamares installer - Calamares (official repo) · GitHub

Manjaro works closely with upstream - having their own repo - Applications / calamares · GitLab

4 Likes

@linux-aarhus
Thank you very much for your reply. Your links to calamares repo helping a lot :+1:

In case someone running into that issue, I opened a bug ticket for manjaro calamares.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.