HFS+ mounting error

Hello every body !

I’m sorry, but i need some help with HFS+ mounting.
I tried to read HFS+ partition from 3.5" HDD (through hdd dock plugged in usb).

I installed hfsprogs with pamac.

$ sudo pamac build hfsprogs

Apparently, no compilation errors. But i have a little doubt: it compiled for kernel 540 and i’m running 510. May there is an issue or not? It seem running as well …

==> Création terminée : hfsprogs 540.1.linux3-4 (mar. 23 févr. 2021 11:41:23)
Running as unit: run-u66.service

I rebooting.

I created a mounting point and checked it.

$ sudo mkdir /mnt/hdd
$ ls /mnt/ -lha
total 16K
drwxr-xr-x  3 root root 4,0K 23 févr. 11:40 .
drwxr-xr-x 18 root root 4,0K 10 févr. 15:20 ..
drwxr-xr-x  2 root root 4,0K 23 févr. 11:40 hdd

I listed partitions :

$ sudo fdisk -l /dev/sdc
Disque /dev/sdc : 232,89 GiB, 250059350016 octets, 488397168 secteurs
Modèle de disque : HDP725025GLA380 
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 4096 octets / 33553920 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 95A9138C-7B52-42EF-8E29-4EB5A85C1E68
Périphérique     Début       Fin  Secteurs Taille Type
/dev/sdc1           40    409639    409600   200M Système EFI
/dev/sdc2       409640 487127591 486717952 232,1G HFS ou HFS+ Apple
/dev/sdc3    487127592 488397127   1269536 619,9M Amorçage Apple

I’m interested by sdc2.

And when i tried :

$  sudo mount -t hfsplus -o remount,force,ro /dev/sdc2 /mnt/hdd/

I got this message :

mount: /mnt/hdd: point de montage non monté ou mauvaise option.
(bad mounting point or bad option)

So i reading some forums and tutorials, i tried different mounting options, but nothing.
I’m bit lost.
If someone can help me, i’ll be thankful.

Have a good day.


It has no bearing on kernel version.

That, remount is a command for an already mounted hfs+ … by default it will have the ro = read only, so i guess you don’t want that.

I suggest to use the file manager to mount it first and then use the command to remount it with write permission (but you have to make sure is not a journaled hfs+ and also you turned off ownership from a MacOS system on that drive), so you will run:

sudo mount -t hfsplus -o remount,force,rw /dev/sdc2 /run/media/YourName/hdd_label


Cool, thank.

I tried without remount option, but no change.
I tried read-write (rw) instead of read-only, but no change.

KDE tried to mount it through Dolphin, but it give me this message :

Une erreur est survenue en accédant à « Untitled ». Le système a répondu :L'opération demandée a échoué: Error mounting /dev/sdc2 at /run/media/adrien/b46f4a46-191a-3236-81f7-92a9ccf3e099: mount(2) system call failed: No such file or directory

Also i created folder : but still bug.

$  sudo mkdir -p /run/media/adrien/b46f4a46-191a-3236-81f7-92a9ccf3e099

I changed chmod to make it similar to other mounted partition : but still bug.

drwxrwxrwx  4 root root 4,0K 10 févr. 01:18 ad17e2f4-5362-4ceb-8865-e04a13eba585
drwxrwxrwx  2 root root   40 23 févr. 15:07 b46f4a46-191a-3236-81f7-92a9ccf3e099


If you reboot your system, there should be no issue. I use this for long time. I mount the drive trough Dolphin and then i remount it trough that command, using the mount point provided by Dolphin …

Bad new : i reboot but it still bug. I thinking Dolphin won’t provide mount point himself !

Une erreur est survenue en accédant à « Dossier Personnel ». Le système a répondu :L'opération demandée a échoué: Error mounting /dev/sdc2 at /run/media/adrien/b46f4a46-191a-3236-81f7-92a9ccf3e0991: mount(2) system call failed: No such file or directory

Let it down : i understood ! HDD is probably dead : smartctl reveal many errors.
It’s old machine…

Thank you very much.