Help with xsession errors

I got this error on .xsession-errors

(gpartedbin:2440): WARNING **: 20:05:08.839: invalid substitution ‘%.’ in fmt string ‘The following list of programme packages is required to support file system %1: 2%.

However, today I was hardly able to start Manjaro due to an error, which I was only able to copy half of and after a few minutes, the system booted.
In gParted two systems appear installed, one Ubuntu and the other Manjaro. The question is which one belongs to Manjaro.



Well if your running system is manjaro … then its nvme0n1p3. As it is mounted to /.


I also notice you have what appear to be multiple ESPs, but with only one of them having the proper flags.

1 Like


@bardo I’ve edited your topic title.

Please see:

1 Like


The problem is on / ?.
On the nvme0n1 Ubuntu was installed, because at the time Manjaro didn’t yet read this type of ‘disc’. Someone on the forum told me to download the trial version, which would solve the problem. So I did, and created a partition on the disc for Ubuntu and a second one for Manjaro, both about the same size and with a partition for EFI. Today I learnt that I have another partition on p4 and on p5 I have strange parameters.
Today, at lunchtime, the computer started very well, but after work it gave an error, which I couldn’t copy, but I know it was about a disc. I just couldn’t copy the number because it suddenly started working.

the p5 looks to be another ESP.
Or rather the one currently used.
It is fat32 and mounted to /boot/efi (the old ESP mount point).
Though it does not have the boot or esp flags.

p4 could be just about anything. Maybe it was intended for SWAP space? Maybe yet another attempt at an ESP? It is ext4, has no flags and is a little over 500MiB.

1 Like

check with UUID

sudo lsblk -fs
cat /etc/fstab 
[thodol@thodol-pc ~]$ 
sudo lsblk -fs

                                                                   0   100% /var/lib/snapd/snap/bare/5
                                                                   0   100% /var/lib/snapd/snap/core18/2796
                                                                   0   100% /var/lib/snapd/snap/core18/2812
                                                                   0   100% /var/lib/snapd/snap/core20/2182
                                                                   0   100% /var/lib/snapd/snap/core22/1122
                                                                   0   100% /var/lib/snapd/snap/core20/2264
                                                                   0   100% /var/lib/snapd/snap/core22/1380
                                                                   0   100% /var/lib/snapd/snap/flameshot/182
                                                                   0   100% /var/lib/snapd/snap/flameshot/183
                                                                   0   100% /var/lib/snapd/snap/gnome-3-28-1804/194
                                                                   0   100% /var/lib/snapd/snap/gnome-3-28-1804/198
                                                                   0   100% /var/lib/snapd/snap/gtk-common-themes/1534
                                                                   0   100% /var/lib/snapd/snap/gtk-common-themes/1535
                                                                   0   100% /var/lib/snapd/snap/kde-frameworks-5-91-qt-5-15-3-core20/1
                                                                   0   100% /var/lib/snapd/snap/snapd/21184
                                                                   0   100% /var/lib/snapd/snap/kde-frameworks-5-qt-5-15-3-core20/8
                                                                   0   100% /var/lib/snapd/snap/snapd/21465
                                                                   0   100% /var/lib/snapd/snap/telegram-desktop/5810
                                                                   0   100% /var/lib/snapd/snap/telegram-desktop/5820
sda1 ext4   1.0         0ee3c73e-a415-4901-aca0-1d17f553ada2                
sda5 ext4   1.0         bdd3a1c2-9869-4f8c-9838-ce18d3bbd711                
sda6 ext4   1.0         60577d90-a009-47d3-adec-e1a177f648ae                
sda7 ntfs               2175302668834263                                    
sdb1 ntfs               046037B76037ADF4                                    
sdb2 ext4   1.0         77209002-c468-474d-8b68-d9fadfb717ce                
sdb3 ext4   1.0         2b71eb0a-08ad-4fed-bd50-2ce19b88efa4                
│    vfat   FAT32       D515-71C0                                           
│    ext4   1.0         e3d686e7-ae42-45c3-bc74-4254fd246731                
│    ext4   1.0         f1160310-9eff-49fa-8781-3b8aa1fbf9aa   71,5G    42% /
│    ext4   1.0         abb9b0da-eea8-497f-930a-d457bd2794e0                
│    vfat   FAT32       849C-4731                             498,7M     0% /boot/efi

[thodol@thodol-pc ~]$ 
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=f1160310-9eff-49fa-8781-3b8aa1fbf9aa /              ext4    defaults,noatime 0 1
UUID=849C-4731                            /boot/efi      vfat    umask=0077 0 2
UUID=a891daeb-4cb9-4d1f-92dc-545f5669ace5 swap           swap    defaults,noatime 0 2
UUID=423631f7-2276-43bc-b2b9-40ab5e1b518b swap           swap    defaults,noatime 0 2

it’s this disc or partition that gives an error when booting, I stare at the screen for a few seconds, and suddenly Manjaro starts. I’ve copied the error onto a sheet of paper and it matches that disc or partition. (UUID=423631f7-2276-43bc-b2b9-40ab5e1b518b swap swap defaults,noatime 0 2)

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I didn’t create that partition. I only had 4, 2 partitions, one for Ubuntu and the other for Manjaro. I created two partitions for Efi, one for each system.

It didn’t create itself. Somehow, you caused it to exist.
I notice your fstab is showing two Swap partitions. This is also rather confusing.

There should only be one ESP (for both systems); usually the first partition on the disk; and that is where your /boot/efi mountpoint should be pointing. Some people add a second ESP when they are multibooting Linux and Windows, but even that isn’t needed.

1 Like

When I installed Manjaro, it asked me to create an efi partition, so I did. When I nstalled Manjaro, it asked me to create a partition for efi, so I did. And it never gave any problems until yesterday.

What you started the thread with is a warning, recorded in the ~/.xsession-errors file
(not an actual error - a warning recorded in a file that has the word error in it’s name)

So: the title of the thread does not seem to reflect the actual issue you have.

In one of your prior posts I notice that you are using snaps - and, because of that, a lot of loop devices are present.

I know from reading here, that there where (and maybe still are) problems with a certain kernel version: linux68

Perhaps you can just avoid using this and boot a different kernel instead - any one of the available LTS kernels, for instance.

Something to try / consider, IMO.

… since there where not

something must have changed since then


I already had Windows installed, but never on this nvme0n 1 drive, because when I changed the mother borad I bought this drive and Windows no longer worked. What’s more, it stopped working and won’t boot or appear in grub. I used to be able to access the Windows files via thunar, but now I can’t even do that.
The error that appears on the screen after the menu is this: I’ve copied the error onto a sheet of paper and it matches that disc or partition. (UUID=423631f7-2276-43bc-b2b9-40ab5e1b518b swap swap defaults,noatime 0 2, but I can’t find it in gParted.

swap does not contain a file system
... defaults,noatime 0 2
does not make sense for swap space
But I don’t know whether that would create the kind of problems you have.

this is surely not what has changed between yesterday (when it worked) and today (where it doesn’t).

There appears to be even Windows in the mix now.

I certainly cannot help with that for complete lack of experience.

1 Like

According to the info you’ve provided, those partitions don’t exist. Comment out those entries.

1 Like