Help with remedying docker blocking internet connection

I have been trying to use my Raspberry Pi 4 (ARM64) for DRM media streaming (digital rights protected content in platforms like Netflix, etc.). This is a known issue; the need for the Widevine extension enabling the playback of DRM content, which is missing by default in ARM64 browsers, as Google hasn’t developed a 64-bit ARM version of the extension. I have a standard Raspbian OS installation, but for a few reasons (including the information described in the link below), I thought I’d give Manjaro a try.

Eventually, I came across a solution described in the archived Manjaro forums below. It involves downloading a docker container to run Chromium with Widevine:

Doing so on a completely fresh Manjaro installation resulting in me not having access to the internet. Installing the container resulted in a new network connection thing appearing in my network manager, I believe it was labeled as a bridge. I had actually tackled this issue beforehand, as I had tried doing something very similar before on my Linux Mint laptop installation. There, after installing a chrome container (from another “link”), I had the same internet connectivity issue. I found a thread in SuperUser, describing some steps to circumvent the issue:
It’s about creating a daemon.json in the docker files to tamper with the networking stuff:
{ "bip": "" }

So, I followed the steps blindly on my laptop (as it’s very technical for my, alas I’m not very tech savvy) which actually resolved the internet issue! So, when I proceeded to download the container through pacman on my Manjaro XFCE on Pi4 and found myself in the same network issue, I just recreated the steps I did on Linux MInt. But the problem persisted, and I don’t know what the problem might be, really. As we speak, I’m actually formatting the SD card to re-write the Manjaro image, to get a clean installation once again.

Hopefully, you could guide me in the right direction in terms I can understand and/or manage, so that I will proceed with in a proper manner. Is there something that I’m missing? Again, my understanding of the issues is extremely superficial. Thanks in advance. Also, first post.

P.S.: I’m not allowed to post links, apparently, so I’ll be kinda cheeky about it. Sorry.

Hi Parattata,

I find myself where you are now. I love trying new systems on my Raspberry Pi 4 with 8GB of RAM. I always overclock it to make it snappier, and the little SBC that could always seem to impress me with what it can achieve.

This being said, I wanted to create a little mini-computer I could take anywhere to perform multiple tasks, but that could also entertain me with streaming services I have, like Netflix. I have everything centralized in Google Chrome, but in order to make this happen, I had to sync my Google Chrome account with Mozilla Firefox, as Chromium can no longer sync with Google accounts… this was the first step I had to make.

Then I had to migrate some software only available on Debian arm64 repositories to work on Arch, and did it with very good success… this allowed me to have some tools I usually have on my Linux systems that were not available even in the AUR for arm64.

For the final steps, I need to handle the DRM issue. When I tried the Chromium OS project for Raspberry Pi, everything works like a charm, and I can have it syncing all data with Google Chrome, and also have DRM working out of the box. So, until now, this is one of the last things I got stuck… the other one is getting a program like Xeoma to display and record with motion sensor, streams from IP cameras.

I also tried installing the Chromium Docker, but can’t get it to work properly. Once installed, when I click to open it, it immediately closes a terminal window after a couple of seconds. And if I try to run it from the terminal as sudo, I get it to run but cannot stream any DRM contents… no internet signal on the streams.

As I said, my project is to have an all in one system in my pocket. Even the code for my Argon One case works better here than in Debian based distros I have tried.

So… who can help us solve this issue? Why can we get Chromium OS working out of the box with Google Sync and DRM on arm64, and we can’t get it working easily on other arm64 systems? Some light, guys… please.

Thank you very much for taking the time to read this post.