Help with Installing T4UH Archer Wifi

A newbie here , are trying to install a T4UH v2 Archer tp-link USB Wireless adaptor. Have managed to get this:
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 2357:010e TP-Link Archer T4UH v2 [Realtek RTL8812AU]
Bus 001 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.10.42-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8700T CPU @ 2.40GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

So can see the hardware device but are unable to get it working. Where do I go from here? Thanks in advance to those who are able to assist.

Welcome to the Manjaro forum. In order to get decent assistance with any issues some basic system information (inxi output) will be necessary. Please read:

In any case a forum search may be of some help as assistance has been requested with this chipset and the issue was solved. Please see the posts below:

All working now. Was unable to get the required results from checking Linux Headers, so re-installed using XCFE, then checked for headers as per wiki guide, that worked, so installed the linux-headers, then enable AUR & Snap, then checked for the RTL8812xxxxxxxx package, installed that, rebooted desktop and the plugged in USB T4UH wireless and hey presto, blue flashing light and then able to connect to wireless at home. So, thanks for the help. I am beginning to like this.

1 Like