Help to install tutanota-desktop


I tried to install tutanota-desktop from AUR (en) - tutanota-desktop
To do this, I added the ‘aarch64’ parameter to PKGBUILD and executed the following commands:

git clone
cd tutanota-desktop/
makepkg -Asrcif

But fatal error occurred as a result of the building:

<--- JS stacktrace --->

FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory
 1: 0xb712ac node::Abort() [node]
 2: 0xa93f08  [node]
 3: 0xd3bb10 v8::Utils::ReportOOMFailure(v8::internal::Isolate*, char const*, bool) [node]
 4: 0xd3bce0 v8::internal::V8::FatalProcessOutOfMemory(v8::internal::Isolate*, char const*, bool) [node]
 5: 0xf1a26c  [node]
 6: 0xf2c20c v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [node]
 7: 0xf08380 v8::internal::HeapAllocator::AllocateRawWithLightRetrySlowPath(int, v8::internal::AllocationType, v8::internal::AllocationOrigin, v8::internal::AllocationAlignment) [node]
 8: 0xf09358 v8::internal::HeapAllocator::AllocateRawWithRetryOrFailSlowPath(int, v8::internal::AllocationType, v8::internal::AllocationOrigin, v8::internal::AllocationAlignment) [node]
 9: 0xeebfe8 v8::internal::Factory::NewFillerObject(int, v8::internal::AllocationAlignment, v8::internal::AllocationType, v8::internal::AllocationOrigin) [node]
10: 0x12925c4 v8::internal::Runtime_AllocateInYoungGeneration(int, unsigned long*, v8::internal::Isolate*) [node]
11: 0x167712c  [node]
/home/user/tutanota-desktop/PKGBUILD: line 34:  7374 Emergency stop         (The memory image has been reset to disk) node desktop --custom-desktop-release --unpacked
==> ERROR: There was a failure in build().

How can this problem be solved?

Tutanota Tuta does not yet support ARM. Sorry.

FYI, no need to do that if you use…

      -A, --ignorearch
           Ignore a missing or incomplete arch field in the build script. This
           is for rebuilding packages from source when the PKGBUILD may be
           slightly outdated and not updated with an arch=('yourarch') field.

This is very strange and upsetting… :confused:

I was advised so here

Isn’t this a universal method?

No, not really. It takes additional effort to support ARM. As I’m sure you’ve notice by now, not all projects support it yet.

I think you missed something there…

Guess who the inhouse packager is? :wink:

1 Like

Surely you are right. And how should it be right?

I’m at a loss for guesses :smiley:

I’m not right. Allan is right. Allan is always right–because he is Pacman. :wink:

…and there are no bugs in Pacman. :smile:

man pacman | less -p BUGS