Help related to understanding extlinux.conf for VIM3PRO MANJARO ARM wayland session

Hi,

I use vim3pro with manjaro arm gnome wayland. Just wanted to know if i can add custom resolution support in wayland session by editing extlinux.conf and adding something like below (bold text):

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/amlogic/meson-g12b-a311d-khadas-vim3.dtb
APPEND initrd=/initramfs-linux.img root=PARTUUID=132b2a67-02 rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 quiet splash video=HDMI-1:1366×768@60 plymouth.ignore-serial-consoles

I saw this from a web link for adding custom resolution using grub.cfg however as vim3 is efi based, so not sure how or where to add this command.
I need to add this custom resolution because i use an old TV with vim3 which does not report proper edid and resolutions to display manager and the available resolutions in wayland all look a bit wrong.

Any help would be appreciated.

Regards
Yasir

I’m not sure if the Vim 3 is actually using extlinux.conf when booting.

Some of the amlogic boards have a convoluted boot system.

@spikerguy would know more in this case.

The Post is duplicated from khadas forum and hyphop and chewitt have already replied with the answer.

Resolution in extlinux is only for linux console if you want to set resolution in xserver then this is not the method.

2 Likes

I added “video=1368x768@60” to extlinux.conf and after reboot the resolution appeared in display settings under xorg as well as wayland sessions.

My problem is now resolved. !!!

1 Like

bro it worked for wayland session in gnome and should work in plasma as well. you can try it as well. add any resolution in extlinux.conf and it will appear as selectable in display settings.

@Strit
this thread can be closed, thanks for support you all.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.